Bug Hunting Session
Bug 59185 - EDITING: Reshaping of textbox does not work right
Summary: EDITING: Reshaping of textbox does not work right
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta2
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-09 23:22 UTC by Thisisnice1000000
Modified: 2015-03-07 12:15 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thisisnice1000000 2013-01-09 23:22:22 UTC
Problem description: After creating a text box and inserting text, if you want the shape to be a different ratio rectangle you can not make it so by pulling the guides on the box its as if the corner guide is the only guide active for all guides on the box.  So, you can resize the box bigger and smaller but you can not change the ratio of the sides.  If word wrap fills the box then the box will automatically get taller. This function should work like it does in Impress and it does not.  Impress' text-box works fine.  This also happened in versions 4.0.0.0.beta2 and beta1.
Windows XP Service pack 3 currently updated.
Phenome II quad core with 4 GB of memory
340 GB of free hdd space 
Nvidia gtx 460 se video card 

Steps to reproduce:
1. .... On drawing either make a text-box and enter some text or copy and paste text letting that procedure make the box and text.
2. .... Select the text-box and try to resize it at each node stretch point.  The function is the same corner pull function at each node.
3. .... Box resizes bigger or smaller but no ratio change of sides.

Current behavior: No ratio change of sides on text-boxes when changing size of text-box

Expected behavior: Text-box shape can be made to have different width to height ratios.  Just like the Impress text-box which is working fine.

              
Operating System: Windows XP
Version: 4.0.0.0.beta2
Comment 1 Joel Madero 2013-01-11 19:32:39 UTC
Works fine in Linux so if it exists must be only Windows.
Comment 2 Jorendc 2013-01-11 21:56:35 UTC
Thanks for reporting!

I can confirm this behavior using Windows 7 x64; LibreOffice Version 4.0.0.1 (Build id: 527dba6f6e0cfbbc71bd6e7b88a52699bb48799)
Comment 3 Thisisnice1000000 2013-01-24 07:00:37 UTC
I have just tested for this bug on the latest daily Version 4.1.0.0.alpha0+ (Build ID: b1d0fd4f969976e2133f8eaa37c1fb8360c20f6) and the text box adjustment is working fine on my system now.  If someone actively fixed this problem thanks very much.  If nobody did well then?

Thanks to everyone who works on these bugs.
Comment 4 Thisisnice1000000 2013-01-24 07:22:17 UTC
I am sorry that I said the bug was gone, its not gone.  I opened the drawing, I was testing this on, somehow in impress not draw.  I thought I was working in draw and the textbox works in impress but not draw.  You ask how I opened a .odg in impress, well I had an impress set of slides testing for another bug fix and used the recent documents under the file Menu and it opened it in impress.  Is that standard or what.  I do not know if I should report that behavior as a bug.  The only reason I noticed is the top line bar said LOdev impress instead of Draw because I had the task menu in impress closed at the time.

So sorry, this bug still exist on my system.
Comment 5 QA Administrators 2015-02-19 15:33:47 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.0.3 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-02-19
Comment 6 Buovjaga 2015-03-07 12:15:44 UTC
Not reproduced -> WFM.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI