Bug Hunting Session
Bug 59195 - undefined: behaviour after restart depending on closing
Summary: undefined: behaviour after restart depending on closing
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta2
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-10 14:05 UTC by paolo_debortoli
Modified: 2015-05-06 14:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description paolo_debortoli 2013-01-10 14:05:06 UTC
Problem description: 

i noted something about on my ubuntu laptop  (running LibreOffice 4.0 beta).  When i close libreoffice using the menu  (file -> exit) and restart it, configuration is saved and behaviour is normal.  but, if I close LibreOffice by simply hitting the 'x' buttomon the window border (or pressin ctrl+f4) and restart it, it shows always kind of errors. mainly: configuration is lost; it says the last document has to be recovered (even if there was no crash) or says 'another instance of the software is running' and it does not start.

Steps to reproduce:
1. open LibreOffice; open a writer document; change the configuration (install themes, icons, gallery images and so on); close it from the menu (file >> exit); restart libreOffice:  the behaviour should be normal without errors;

2. open a writer document; change the configuration (install themes, icons, gallery images and so on); close it simply by closing the window (x buttom  or ctrl+f4).  when you restart libreoffice you may see error messages:  another instance of the software running;  document lost to recover; configuration lost.


i am not sure wether it might be due to the machine or operating system (temp files)  or just an occasional / temporary problem.       
Operating System: Ubuntu
Version: 4.0.0.0.beta2
Comment 1 Joel Madero 2013-01-10 20:28:23 UTC
Cannot reproduce with Version 4.1.0.0.alpha0+ (Build ID: a0d2c3c59fbe9324395152e544890fe298b6043)

Marking as WFM

@Reporter - please retest with RC coming out in a few days. Make sure to reset your user profile as these are pre-releases and maybe something went weird with your profile.


If you reset your profile and test on RC1 and there is still an issue, please reopen the bug as REOPENED.

Thanks for helping us out!
Comment 2 paolo_debortoli 2013-01-11 08:41:14 UTC
there are other reports about similar problems  (I don't know exactly the problem):

(from facebook) I want to download the portable version on my UsB, but when I try tells me "Unable to close all applications and try again openoffice". But I have no plans to open the installation file.

(from libreoffice-users ml) I'm trying to use LibreOffice (latest version) in a class I'm teaching.  The  computer lab we are using is made up of thin clients that attach to a  Windows 2008 R2 server with RDP.  All of the students log in with the same user account (I am not able to change this).  The first computer (terminal  session) to open LibreOffice Writer works fine.  On all other machines, when  opening LibreOffice, the user instantly sees the document recovery screen  asking if they want to recover whatever document was open in session 1.  I  can cancel the document recovery and Writer opens to a new document.  However, after about 1 minute (even with no activity), it crashes and
 closes.   I thought perhaps temp files were part of the problem, but each session that  is logged in to the server gets its own temp directory.  Looking at the  LibreOffice Paths in the Tools->Options menu, the Temp path is correctly set  to be unique per session.  I also tried changing the Backup path to %temp%  thinking that this might resolve the document recovery issue, but it did  not.
Comment 3 paolo_debortoli 2013-01-12 00:29:39 UTC
one solved

(from libreoffice-users ml)  It appears that
LibreOffice creates some sort of session/temp file within the user profile
folder while LO is in use.  The user profile folder was located in
c:\users\username\appdata\roaming\LibreOffice\3.  When more than one
terminal session was logged in using the same account name LO in each
session is trying to read/write files in the same folder causing conflict.
Looking through documentation, it appears that this path is configurable via
the bootstrap.ini file in C:\Program Files\LibreOffice 3.6\program.  There
is a UserInstallation variable in there that utilizes a $SYSUSERCONFIG
variable.  My system did not have this env variable set so it was using
whatever the default path was for LibreOffice. I created a batch script that is run on login that creates an env variable name SYSUSERCONFIG and points it to a temp file location that is session-specific.  That way each terminal session gets its own path. This seems to have resolved my problem.
Comment 4 paolo_debortoli 2013-01-12 16:46:57 UTC
also. i updated to LO 4.0 RC1 and tested it again. no problem with configuration or stability, but sometimes (as when i tried to remove beta2) there is a file 'soffice' which persists running in the ram after LO has been closed (and in case people get errors such as 'another instance running').  closed it with system monitor.
Comment 5 Joel Madero 2013-01-16 17:17:57 UTC
I am marking this as NEW to see if a developer has an opinion about your workaround and comments. 

The last comment seems to be a different issue though.
Comment 6 QA Administrators 2015-02-19 15:50:06 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.0.3 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-02-19
Comment 7 Buovjaga 2015-03-08 16:15:21 UTC
As this has received no interest from devs in over 2 years and no one has actually confirmed this, I'm setting to NEEDINFO.

Paolo: please give us an update with the latest 4.4.x version of LibreOffice.

Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 8 QA Administrators 2015-05-06 14:22:18 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INVALID due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

-- The LibreOffice QA Team 

This INVALID Message was generated on: 2015-05-06

Warm Regards,
QA Team