Bug 59305 - Libreoffice 4.0 Visio Filter - component positioning shift
Summary: Libreoffice 4.0 Visio Filter - component positioning shift
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta2
Hardware: Other All
: low normal
Assignee: Fridrich Strba
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-13 03:12 UTC by NoOp
Modified: 2013-03-22 08:24 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example .vsd file used (134.00 KB, application/vnd.visio)
2013-01-13 03:14 UTC, NoOp
Details
PDF from .vsd file. (27.70 KB, application/pdf)
2013-01-13 03:15 UTC, NoOp
Details
LO 4.0 Windows pdf (73.43 KB, application/pdf)
2013-01-13 03:17 UTC, NoOp
Details
LO 4.0 Linux pdf (68.49 KB, application/pdf)
2013-01-13 03:17 UTC, NoOp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NoOp 2013-01-13 03:12:31 UTC
Visio component objects shift slightly when .vsd is imported into LibreOffice.

The shift varies between Windows and Linux versions:

Version 4.0.0.0.beta2 (Build ID: 4104d660979c57e1160b5135634f732918460a0

Attaching 4 files:
StoreNetwork_generic.vsd - example Visio Technical 5.0 file
Visio-StoreNetwork_generic.pdf - pdf of example Viseo file - use as benchmark.
StoreNetwork_generic_LO4Win.pdf - pdf of example Viseo file exported from LO.
StoreNetwork_generic_LO4Linux.pdf - pdf of example Viseo file exported from LO.
Comment 1 NoOp 2013-01-13 03:14:32 UTC
Created attachment 72939 [details]
Example .vsd file used
Comment 2 NoOp 2013-01-13 03:15:53 UTC
Created attachment 72940 [details]
PDF from .vsd file.
Comment 3 NoOp 2013-01-13 03:17:12 UTC
Created attachment 72941 [details]
LO 4.0 Windows pdf
Comment 4 NoOp 2013-01-13 03:17:53 UTC
Created attachment 72942 [details]
LO 4.0 Linux pdf
Comment 5 Jorendc 2013-01-14 19:24:42 UTC
@Fridrich: If you already assigned yourself to this bug, I suppose you can confirm it? If so, can you please set this bug as NEW; If you still need an independent test, can you always 'ping' me again.

Thanks,
Joren
Comment 6 Joel Madero 2013-01-15 19:03:32 UTC
Confirmed:

Marking as: 
Assigned (confirmed + assigned to someone)
Normal (can prevent high quality work or consistent quality work between products)
Low (default of medium, put as low because this feature isn't used by a lot of our users)
Comment 7 Fridrich Strba 2013-03-22 08:24:24 UTC
Hello, I checked the attached file and I see that there are some differences in position and wrapping of a text. These are principally due to the way font substitution works on Linux or Windows. The problem here is that we will never be able to achieve pixel-by-pixel fidelity of the documents. We have to rely on the underlying font engine to lay the text for us.

I am sorry, but I cannot do much with this one. That is why I close it as NOTOURBUG.