Bug Hunting Session
Bug 59317 - Conditional formatting: Use better text styles by default
Summary: Conditional formatting: Use better text styles by default
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.1 rc
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Conditional-Formatting
  Show dependency treegraph
 
Reported: 2013-01-13 10:42 UTC by Gerry
Modified: 2017-04-08 18:52 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerry 2013-01-13 10:42:11 UTC
Thanks for the new conditional formatting dialog. I would like to suggest two small enhancement requests which improve usability with regards to cell styles for conditions:

(a):
It would be good if the cell style which is selected by default in the dialog is not the style named "Default", but rather the style in the list named "Result". Suggestion: Set the style "Result" as style selected by default for conditions in the dialog.
Rationale of this request: 100% of users want to choose a style which is different from the default cell style, because they want to see the result of conditional formatting in their sheet.

(b)
Please add two more cell styles to the list of cell styles in the dialog which are very commonly used by users: 
* Style "Positive values (green font colour)" and
* Style "Negative values (red font colour)"
Rationale of this request: From all spreadsheets using conditional formatting I have see so far, the vast majority of sheets just marks positive and negative values. The set-up of this in Calc is a bit cumbersome, because everyone needs to define two new cell styles when they simply want to mark values >=0 and <0

System: Ubuntu 12.10, 64-Bit, LibreOffice Version 4.0.0.1 (Build ID: 527dba6f6e0cfbbc71bd6e7b88a52699bb48799)
Comment 1 Markus Mohrhard 2013-01-13 13:34:30 UTC
@Astron: What is the opinion of the UX team about this?
Comment 2 Stefan Knorr (astron) 2013-01-15 17:24:08 UTC
Hi all.

(a) Makes sense to me. Why would you want to apply the Default style, ever?

(b) Makes sense to me, too. BUT: for this to work, we'd need condition presets ... which we don't have (and which I didn't include for normal rules in my mockup either). Thus the best we can do right now, is set up styles for red text and green text, I guess.


Setting Unconfirmed => New. Modified bug title to be shorter.
Comment 3 Markus Mohrhard 2013-01-26 01:18:02 UTC
(In reply to comment #2)
> Hi all.
> 
> (a) Makes sense to me. Why would you want to apply the Default style, ever?

Ok. I can change that to the one you suggest. Should I use "Result" instead?

> 
> (b) Makes sense to me, too. BUT: for this to work, we'd need condition
> presets ... which we don't have (and which I didn't include for normal rules
> in my mockup either). Thus the best we can do right now, is set up styles
> for red text and green text, I guess.
> 

Ok. Can you suggest two designs for styles. Please note that they will be hard-coded into calc code and are also visible in the normal cell style selection.
Comment 4 Stefan Knorr (astron) 2013-01-26 12:18:10 UTC
(a) Yes, Gerry's suggestion of Result sounds good.

(b) Okay, suggestions:
Green: Default font, Regular, Font size 10pt, Colour "Chart 4"
Red: Default font, Italic, Font size 10pt, Colour "Chart 5" *


* Italic in the hope that this makes it easier for colourblind users.
Comment 5 Stefan Knorr (astron) 2013-01-26 12:19:24 UTC
Oh and names for the styles would of course be something like "Positive Value" and "Negative Value".
Comment 6 Gerry 2013-01-26 16:00:35 UTC
@Markus @Astron:

Thanks. All sounds good.

I also like Astron's idea to have the negative values in italics. This helps for colourblind users, but also for printouts on monochrome printers.

Thanks!
Comment 7 Markus Mohrhard 2017-04-08 18:52:28 UTC
Should be implemented by the new pre defined formats.