Bug Hunting Session
Bug 59415 - UI: Allow 'Find & Replace - Styles' for Styles used as CONDITIONAL FORMATTING
Summary: UI: Allow 'Find & Replace - Styles' for Styles used as CONDITIONAL FORMATTING
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: Confirmed:4.3.0.0.alpha0+2013-12-19:U...
Keywords:
Depends on: 59413
Blocks: Conditional-Formatting Find-Search
  Show dependency treegraph
 
Reported: 2013-01-15 12:22 UTC by Rainer Bielefeld Retired
Modified: 2017-04-08 22:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2013-01-15 12:22:20 UTC
Steps how to reproduce  with server  installation of  "LOdev  4.0.0.1+   -  ENGLISH UI / German Locale  [Build ID:  fa16c2d432c6054edd2dede556876f5455b7e26)]"  {tinderbox: Win-x86@6, pull time 2013-01-15 06:44:14} on German WIN7 Home Premium (64bit) with own separate User Profile 
0. Download  Attachment 73076 [details] for Bug 59413
1. Open sample document from LibO Start Center
2. Click C10
3. <f11> for 'Styles'
4. Apply Style "findme" to C10 by doubleclick on style in Styles pane
5. Menu 'Edit -> Find & Replace -> More Options - Search For Styles'
6. Apply Style "findme" in 'Search for'
7. 'Find all'
   Expected: also cells in Column B found
   Actual: only C10 found, CF styles in column B ignored.

This never worked in LibO, inherited from OOo

This one can not be fixed without resolved "Bug 59413 - UI: Allow Styles only used in CONDITIONAL FORMATTING for 'Find & Replace - Styles'"
Comment 1 Robinson Tryon (qubit) 2013-12-20 13:18:15 UTC
(In reply to comment #0)
Repro Steps:
> 0. Download  Attachment 73076 [details] for Bug 59413
> 1. Open sample document from LibO Start Center
> 2. Click C10
> 3. <f11> for 'Styles'
> 4. Apply Style "findme" to C10 by doubleclick on style in Styles pane
> 5. Menu 'Edit -> Find & Replace -> More Options - Search For Styles'

Edit -> Find & Replace -> Other Options -> Search for Cell Styles

> 6. Apply Style "findme" in 'Search for'

In the 'Search for' dropdown, I selected the style 'findme'.

> 7. 'Find all'
>    Expected: also cells in Column B found
>    Actual: only C10 found, CF styles in column B ignored.

Neither 'Find' nor 'Find all' found *any* results -- the search didn't even return cell C10.

Interestingly, if I click on a different cell (e.g. C9), and then try 'Find', the currently selected cell will change to C10 (but there'll be no notification/indication in the Find & Replace dialog that a result has been found. If I click on C9 and then try 'Find All,' no results are shown and the currently selected cell does *not* update to cell C10.

RESULT: I didn't get precisely the same results, but this still looks like a bug (or a handful of related bugs)

---

Bug Status: NEW
Comment 2 Markus Mohrhard 2017-04-08 22:45:17 UTC
See the comment in Bug 59413 for the explanation why this is not a good idea.