Bug 59433 - Missing localization for Extension Manager with some locales
Summary: Missing localization for Extension Manager with some locales
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
4.0.0.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-15 18:31 UTC by Mihkel Tõnnov
Modified: 2013-01-20 19:01 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mihkel Tõnnov 2013-01-15 18:31:42 UTC
Although translated in Pootle, the Extension Manager remains partly unlocalized if LibO UI language is set to certain languages, including my native Estonian. The buttons "Help" and "Close" are translated in all cases, as are the names and descriptions of the extensions themselves, but for some languages the rest is shown in English.

This has been this way for as long as I can remember in 4.0 branch -- I attributed it to build being out of sync with Pootle, but apparently this is not the case, as the partial localization is still present in 4.0.0 RC 1, which has been synced AFAIK. Tried with a blank user profile on Linux x86 (Debian) and Windows XP.

Tested with some other languages as well, here are the results:
affected by this bug: Estonian, Italian, Esperanto, Spanish, Hungarian, Basque, Japanese (all have the strings translated in Pootle) + possibly more;
unaffected: French, German, Dutch, Finnish, Swedish, Norwegian Bokmål, Danish, Scottish Gaelic, Catalan, Portuguese, Romanian, Greek, Russian + probably more.
Comment 1 Martin Srebotnjak 2013-01-15 19:19:59 UTC
Slovenian translation strings seem to show properly.
Comment 2 Mihkel Tõnnov 2013-01-20 19:01:21 UTC
Apparently this is somehow caused by Pootle, see http://listarchives.libreoffice.org/global/l10n/msg05397.html

Looks like this is not our bug -- resolving as such.