Download it now!
Bug 59650 - FILEOPEN: in particular .DOCX table does not fit page size and there is no right margin of the document at all
Summary: FILEOPEN: in particular .DOCX table does not fit page size and there is no ri...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: All All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-21 07:44 UTC by Timon
Modified: 2015-04-10 11:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example 26.docx - original file saved in MSO 2007 SP3, *.jpg - how document looks like in MS Office and LibreOffice (415.07 KB, application/x-zip)
2013-01-21 07:44 UTC, Timon
Details
*.pdf - .docx converted to pdf to see all file content, *.jpg - how document looks like in In LibreOffice Version 4.0.2.1 (279.79 KB, application/x-zip)
2013-03-19 07:27 UTC, Timon
Details
PDF printed from Mac Word 2011 (152.01 KB, application/pdf)
2015-04-10 10:41 UTC, Matthew Francis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timon 2013-01-21 07:44:33 UTC
Created attachment 73357 [details]
Example 26.docx - original file saved in MSO 2007 SP3, *.jpg - how document looks like in MS Office and LibreOffice

LibO Version 4.0.0.1 (Build ID: 527dba6f6e0cfbbc71bd6e7b88a52699bb48799) on Windows XP SP3 Russian

We have document with a table that contain contract clauses.

In LibO 4 table does not fit page size (in some lines letters are outside the border of the page (see Example 26 LibO 4.JPG), there is no right margin of the document at all.

In MSO 2007 SP3 everything is fine.
Comment 1 Joel Madero 2013-01-21 22:52:58 UTC
I can confirm the behavior on 3.6.3.2, changing version.

@Timon - version is the oldest version we can confirm the behavior.

Marking as:
New (confirmed)
Normal (can prevent high quality work)
High (normal default is medium but this is quite common and really can prevent a user from using LibreOffice completely).


Thanks for reporting Timon
Comment 2 Timon 2013-03-19 07:27:54 UTC
Created attachment 76741 [details]
*.pdf - .docx converted to pdf to see all file content, *.jpg - how document looks like in In LibreOffice Version 4.0.2.1

In LibreOffice Version 4.0.2.1 (Build ID: 7e5467ff8f30d821f4fbf69cb2769163eb64c2c) on Windows XP SP3 Russian there are changes when viewing document.

Now table fit page size, but document contains only 1 page and the last item is 7.4 (but in fact document contains 4 pages and have items 8, 8.1, 8.2, 9, 9.1, 9.2, 9.3, 9.4, 9.5, 10, 10.1, 10.2, 10.3, 11 and application on a separate page) - see attached .pdf, converted from .docx file to see all file content.
Comment 3 Timon 2014-03-14 05:04:25 UTC
LibO Version 4.2.2.1 (Build ID: 3be8cda0bddd8e430d8cda1ebfd581265cca5a0f) on Windows XP SP3 Russian

In LibreOffice 4.2.2.1 table again does not fit page size (in some lines letters are outside the border of the page, there is no right margin of the document at all. Just after loading file, LibreOffice shows that there are 36 pages in it, after some time only 4 remains. Once I even could scroll all 36 pages (after page 4 all other pages are blank).
Comment 4 Timon 2014-08-01 04:35:32 UTC
In LibreOffice Version 4.3.0.4 (Build ID: 62ad5818884a2fc2e5780dd45466868d41009ec0) on Windows XP SP3 Russian.

Better than it was, but not perfect.

Now table again fit page size, document contains only 2 pages. On the first page the last item is 7.4 (but in fact missed items 8, 8.1, 8.2, 9, 9.1, 9.2, 9.3, 9.4, 9.5, 10, 10.1, 10.2, 10.3, 11). Supplement is shown on a second separate page.
Comment 5 Matthew Francis 2015-04-10 10:41:07 UTC
Created attachment 114716 [details]
PDF printed from Mac Word 2011
Comment 6 Matthew Francis 2015-04-10 10:51:28 UTC
The original width issue with this file has since been resolved.

The issue with the missing content at the bottom of the table is a separate problem which postdates this report.

Status -> RESOLVED WORKSFORME

(I will find or make a suitable bug for the later issue and comment here)
Comment 7 Matthew Francis 2015-04-10 11:06:52 UTC
Bug for floating tables not splitting across pages: bug 61594