Bug 59665 - Not possible to save changes in specific MS Word 2003 XML file
Summary: Not possible to save changes in specific MS Word 2003 XML file
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: MSO-XML2003
  Show dependency treegraph
 
Reported: 2013-01-21 15:03 UTC by Jonas Jasas
Modified: 2018-11-01 18:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
file that can help reproduce bug (14.69 KB, text/xml)
2013-01-21 15:03 UTC, Jonas Jasas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonas Jasas 2013-01-21 15:03:54 UTC
Created attachment 73387 [details]
file that can help reproduce bug

Steps to reproduce:
Open attached file (or create one in MS Office 2003 XML format)
Edit it and save it.

No changes are saved in edited file.
Comment 1 m.a.riosv 2013-01-24 01:10:58 UTC
Hi Jonas thanks for reporting.

Reproducible.
Win7x64 Ultimate
Version 3.6.5.2 (Build ID: 5b93205)
Version 4.0.0.1 (Build ID: 527dba6f6e0cfbbc71bd6e7b88a52699bb48799)

Adding a couple of paragraphs with a few text as 123456
First save and reload, the new two paragraphs are there but the text not if the text is in the last paragraph.
Also new paragraphs styles appear.
Comment 2 m.a.riosv 2013-01-24 01:20:19 UTC
I think Blocker status it is not right, the issue do not affect the LibreOffice operability. Only a particular file saved in a non native format.

Saving a new file in the xml 2003 format, I can not reproduce the lost text issue.
Remains the appear of new paragraph styles.
Comment 3 Jonas Jasas 2013-01-24 15:08:34 UTC
Did you try to reproduce with attached file?
What else I can provide to help you reproduce this bug?
Comment 4 m.a.riosv 2013-01-24 15:27:35 UTC
Yes Jonas,
I see the issue with your file, but seems is only the text in the last paragraph what is loosed. With a blank paragraph after the text paragraph, the text remain.
This is why I did a try with a new file.

In fact the status is NEW.
Comment 5 QA Administrators 2015-04-19 03:21:31 UTC Comment hidden (obsolete)
Comment 6 Buovjaga 2015-06-16 10:34:57 UTC
Still repro.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 80ec99db4325a439a8a3f1d420d0a80f8bf9c439
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-16_00:00:20
Locale: fi-FI (fi_FI)
Comment 7 QA Administrators 2016-09-20 10:02:12 UTC Comment hidden (obsolete)
Comment 8 Timur 2018-11-01 17:34:21 UTC Comment hidden (obsolete)
Comment 9 Timur 2018-11-01 18:27:55 UTC
Repro 5.1 but no repro 6.2+, changes saved. So WFM.
There's another issue now, text if crossed, so formatting wrong.