Bug 59686 - : instance running after application has been closed
Summary: : instance running after application has been closed
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
(earliest affected) release
Hardware: Other Linux (All)
: high normal
Assignee: Not Assigned
Whiteboard: BSA
Keywords: regression
Depends on:
Reported: 2013-01-22 00:57 UTC by paolo_debortoli
Modified: 2017-05-31 10:46 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:

image of the system monitor wit instance running after libreoffice has been closed (73.74 KB, image/png)
2013-01-22 00:57 UTC, paolo_debortoli

Note You need to log in before you can comment on or make changes to this bug.
Description paolo_debortoli 2013-01-22 00:57:49 UTC
Created attachment 73416 [details]
image of the system monitor wit instance running after libreoffice has been closed

Problem description: I closed libreoffice window and it was ok. but when I tried to clean the system cache it answered 'libreoffice is still running'.  I opened the system manager and it showed to objects running in memory:  ooosplash  and  soffice.bin.  I closed ooosplash and everything else closed automatically.  cleaned the system cache and everything was fine.

Steps to reproduce:
1. open libreoffice, documents, do some operations
2. click on the window 'x' bottom to close the window
3. check system monitor and running processes to look for ooosplash and soffice.bin

Current behavior:  some files/components still running in memory

Expected behavior:   when you close it, everything should be closed, no more instance running

Operating System: Ubuntu
Version: rc
Comment 1 Joel Madero 2013-01-23 19:14:59 UTC
Do you have the quickstarter enabled? Tools -> Options -> Memory?
Comment 2 paolo_debortoli 2013-01-23 22:19:37 UTC
hi. actually I don't know; i don't find the voice in the options and don't see it in the system tray.  it doesn't show always the behaviour...  however it happens often.  I have also found an error log of java related to soffice.bin...  may be it depends on that.
Comment 3 Joel Madero 2013-01-24 02:21:19 UTC
I see what you mean, I just installed RC and I don't see quick starter but I did have soffice stuff running after I closed libreoffice. I'm not sure if this is intentional or not but I'm marking as NEW and raising priority. We shouldn't allow such non transparent stuff to happen -- a dev might disagree but it took me a few minutes to figure out why my language wasn't changing and it was because soffice was running in the background.

I think this can be called a regression as before finding quick starter was easy, and by default it was off
Comment 4 Toni Ballesta 2013-09-21 22:34:40 UTC
At version 4.0.5 with Clang 3.3 on FreeBSD 9.1, the problem is not solved. I need kill manually soffice.bin or oosplash.
Comment 5 ign_christian 2014-07-07 13:15:16 UTC
I can't see that in LO and - Ubuntu 12.04 x86, without quickstarter, using OpenJDK 7u55

@Paolo, please mark RESOLVED WORKSFORME if it's resolved, unless UNCONFIRMED
Comment 6 Matthew Francis 2015-02-12 06:41:12 UTC
I'm calling this one. I've never seen stale processes on any recent version (during a great deal of testing), and the system tray quickstarter seems to work as intended - when it's running, an icon is visible

Comment 7 Heinz Repp 2016-04-17 15:04:42 UTC
I experience this bug since upgrade to closing Libreoffice does sometimes not close it, it stays open and is unresponsive. I think I saw it with Calc, having already saved the open document, so no data loss when I killed this process. This time it was with Base, closing the database led to the same unresponsive zombie. In system monitor I saw two oosplash processes still running, and after killing both of them Libreoffice closed properly. It seems to me that those oosplash processes fail to terminate, and Libreoffice on close waits for them to close beforehand. My feeling is the fault is within oosplash.

System: Ubuntu x86 14.04 with Libreoffice ppa enabled; note there is NO quickstarter in Ubuntu, so don't mix this bug up with quickstarter issues.

I did reopen this bug, because I saw it was never resolved properly, just some people that did not experience this bug (as every bug has plenty of) closed it WFM, but as you can see for me it does NOT work.
Comment 8 Joel Madero 2016-04-17 16:41:21 UTC
Please don't change the version. Also, REOPENED is wrong - moving to UNCONFIRMED.
Comment 9 Buovjaga 2016-04-26 11:57:03 UTC
(In reply to Heinz Repp from comment #7)
> System: Ubuntu x86 14.04 with Libreoffice ppa enabled; note there is NO
> quickstarter in Ubuntu, so don't mix this bug up with quickstarter issues.

There is a quickstarter in Ubuntu, though.
Tool-> Options-> LibreOffice-> Memory-> [X] Enable systray Quickstarter
Comment 10 tommy27 2016-10-10 11:53:09 UTC
it looks like the bug was confirmed in comment 7.

@Heinz Repp
are you still reproducing it with latest 5.1.5 or 5.2.2 releases?

if YES, change status to NEW
Comment 11 QA Administrators 2017-05-02 11:37:14 UTC Comment hidden (obsolete)
Comment 12 QA Administrators 2017-05-31 10:46:39 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INSUFFICIENTDATA due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

Warm Regards,
QA Team