Bug 59722 - FILESAVE DOCX document is saved corrupted
Summary: FILESAVE DOCX document is saved corrupted
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta2
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-22 17:19 UTC by Alexander Nolting
Modified: 2013-02-12 17:21 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Nolting 2013-01-22 17:19:08 UTC
Edited a Word Dowcument with .docx extension. After Saving the file is unreadable by MS Word or any other programm like Calligra Words.

The Error Message from MS Word say the following:

Ungültiges qualifiziertes Zeichen.

Position: Komponente: /word/styles.xml, Zeile: 2, Spalte: 8348


in English:

Invalid qualified characters.

Position: Component: / word / styles.xml, Line: 2, Column: 8348

File is attached. Can't attache the file to the bug. Please get in contact with me by email.
Comment 1 Joel Madero 2013-01-23 17:02:56 UTC
Please send me the file to test via email Thanks!

After you email me please reopen this bug as UNCONFIRMED so I make sure to test it.
Comment 2 Joel Madero 2013-01-23 18:27:28 UTC
I received the file, and here are my notes:

I opened up the original file with LibreOffice 3.6

Saved file as NAME_36.docx
Closed File

Opened File with Version 4.1.0.0.alpha0+ (Build ID: 593e6ed34f89c8abba41a771d5de05aebd600fb)

Saved file as NAME_40
Closed file

Opened original, 36 and 40 with Microsoft Office 2007

All opened with no problem. So one of four things occurring:

1. Issue has been resolved between beta2 and current master - most likely

2. I missed a step

3. Your profile needs reset.

4. Locale issue - very unlikely I think

I'm going to close this as WFM. 

@Alexander - if you could do two things:

a) Reset your profile for 4.0
b) Install RC2 when it is released in the coming days, retest the bug.

If it's still an issue after these two things please reopen the bug as UNCONFIRMED and I'll test again. If I missed any steps please let me know where and I'll retest.
Comment 3 Alexander Nolting 2013-01-24 07:42:27 UTC
Hi Joel,

I deleted .openoffice from my home. Opened the Word and saved without any changes. The becomes unreadable again.

My build is: Version 4.0.0.1 (Build ID: 527dba6f6e0cfbbc71bd6e7b88a52699bb48799

Regards
Alex
Comment 4 Jorendc 2013-01-24 19:06:20 UTC
Can't reproduce using Mac OSX 10.8.2 and LibreOffice 4.0.0.1 rc1 and LibreOffice Version 4.1.0.0.alpha0+ (Build ID: b1d0fd4f969976e2133f8eaa37c1fb8360c20f6)
TinderBox: MacOSX-Intel@1-built_no-moz_on_10.6.8, Branch:master, Time: 2013-01-24_00:28:35.

Saved with the 2 LO versions and I open the files with succes using Word for Mac 2011.

I CAN reproduce the error with the other document. When I open that document with Word for Mac it result in an error.

Error message:
*****************
The Open XML file <filename>_libre.docx cannot be
opened because there are problems with the
contents or the file name might contain invalid
characters (for example, \/).

Details:
No error detail available
Location: 2
*****************
Comment 5 Florian Reisinger 2013-01-26 14:24:44 UTC
Joel, could you please send me the file?
Comment 6 Florian Reisinger 2013-01-27 08:34:24 UTC
NOT REPRODUCEABLE
with
Version 3.6.4.3 (Build ID: 2ef5aff
)
Version 4.1.0.0.alpha0+ (Build ID: 2b17d6c14d226b1973c87ff161586c39899e403)
TinderBox: Win-x86@6, Branch:master, Time: 2013-01-26_00:10:54

Version 4.0.0.2 .0.2 (Build ID: 5991f37846fc3763493029c4958b57282c2597e)
@ Win7 x64 SP 1

I change the status to RESOLVED WORKSFORME. Feel free to change it back to REOPENED, if you are able to reproduce it with the latest RC...
Comment 7 Alexander Nolting 2013-01-28 14:06:43 UTC
Tested it again with Version 4.0.0.2 .0.2 (Build ID: 408fe71bd18616c467b3dcd7ab6756528ffcae2)

File saved corrupted. Word complains again about the Invalid qualified character in /word/styles.xml.

Please tell what to check of my Ubuntu installation.

Alex

PS: And pleas estop telling that it works for you. When there is something wrong related to the installation of Libreoffice or the Ubuntu itself then I'm glad to get some hints and tips how to clean up this.
Comment 8 Joel Madero 2013-01-28 16:10:11 UTC
Alexander - If 5 QA people can't reproduce, WORKSFORME is the correct status. It's sounding like your specific environment is causing the problem. We haven't had one other complaint about a problem like this despite worldwide testing of LibreOffice 4 pre-release.

We can mark it as NEEDINFO as well, maybe you providing more information about your setup will give us hints as to what's going on.

Lastly, have you tried installing a nightly build recently to see if you still have this issue? Leaving as UNCONFIRMED is misleading as it then it pops up every time in our queries as almost "not tested" but in this case, this bug has been tested extensively and we simply cannot reproduce the issue.

Please test a recent nightly build.

As for what to test on your Ubuntu system, I would suggest trying to setup a new user and try to repeat the steps as a new user. Even better would be to try on a live distro from a USB drive - this way we know that it's a completely fresh install of Ubuntu.

Please let us know your results, I'll leave as UNCONFIRMED for now but we can't just let it sit here when we've had so many testers look at it and simply cannot reproduce. 

Thanks for your understanding and patience
Comment 9 Joel Madero 2013-02-07 16:52:20 UTC
Changing back to NEEDINFO as we've tested this exhaustively and cannot reproduce.

Alexander - can you send me a corrupted .docx file that you create? Maybe this will lead to something.

Thanks again for your patience
Comment 10 Alexander Nolting 2013-02-12 11:55:39 UTC
Hello Joel,

I'm very sorry letting you waiting so long.

I tried now LO 4.0.0.3 and get the same issue. The document is saved corrupted.

I had send you this on gmail.

Regards
Alex
Comment 11 Alexander Nolting 2013-02-12 11:56:24 UTC
Changed version to 4.0.0.3.
Comment 12 Joel Madero 2013-02-12 16:06:52 UTC
@Alexander - the version field is the oldest version that you saw the problem, not the newest it's been tested on.

I will test the file you sent me now and report back
Comment 13 Joel Madero 2013-02-12 16:23:18 UTC
I can open both of the files you sent me from within Microsoft Office 2007 with no problem. I also opened the original file, edited it a bit, saved it again and then opened it successfully with Microsoft Office 2007.

I suspect it's your MSO.....maybe you found a Microsoft bug. Will get one other person to test before closing this one.
Comment 14 Jorendc 2013-02-12 17:21:51 UTC
(In reply to comment #13)
> I can open both of the files you sent me from within Microsoft Office 2007
> with no problem. I also opened the original file, edited it a bit, saved it
> again and then opened it successfully with Microsoft Office 2007.

I also can't reproduce the reported behavior. 
Opening both files using LibreOffice 4.0.0, edit it, open it using Word for Mac 2011 -> opens without problem
Opening both files without altering in LibreOffice -> opegoodns also without problem

> I suspect it's your MSO.....maybe you found a Microsoft bug. Will get one
> other person to test before closing this one.

I agree with that; therefore I mark this as RESOLVED NOTOURBUG ... it's tested that much using multiple independent systems/platforms. I think that's a good conclusion. If someone else can reproduce the behavior of the reporter, please feel free to REOPEN.