Bug 59766 - docx import switches all content font to greek/cyrillic characters in Symbol font
Summary: docx import switches all content font to greek/cyrillic characters in Symbol ...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-23 15:08 UTC by pcook9
Modified: 2013-11-17 19:00 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
docx that switches content font in libre (47.14 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-01-23 15:08 UTC, pcook9
Details
doc file (docx save-as doc) that opens ok (83.00 KB, application/msword)
2013-01-23 15:08 UTC, pcook9
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pcook9 2013-01-23 15:08:01 UTC
Created attachment 73528 [details]
docx that switches content font in libre

Original .docx opens fine in MS-Word 2007 on Win7 x64 Enterprise SP1.  The example content ("blah blah, yadda yadda, rabbit rabbit") displays in arial font.
In Libre 3.5.4.2 (Build ID: 350m1(Build:2)) on Ubuntu 10.04 LTS x86 and Libre 3.6.2 on RedHat Enterprise Server 5.8.0.3 it opens but all the the text content has switched to Symbol font (I'm guessing its either greek/cyrillic chrs, I'm not sure).  It may well happen on other combinations and releases, I've just quoted the ones I have to hand and have tested it on.
Attachment 1.

If the original .docx is opened in Word and saved-as .doc, the resulting .doc opens fine in Libre.
Attachment 2.


I cant give you any provenance on the history of the docx file and what combination of tools and save/save-as it went through before arriving in its current state.  I have stripped the text content down to a minimal test case before submitting and confirmed the problem remains.
Comment 1 pcook9 2013-01-23 15:08:54 UTC
Created attachment 73529 [details]
doc file (docx save-as doc) that opens ok
Comment 2 pcook9 2013-01-23 15:14:54 UTC
Doh, sorry, attach 1 / 2 were meant as descriptive comments, not hotlinks.
Comment 3 Urmas 2013-01-23 16:42:18 UTC
Tentatively marking as Linux issue.
Comment 4 pcook9 2013-01-24 11:10:18 UTC
(In reply to comment #3)
> Tentatively marking as Linux issue.

Further local testing.  We're getting the same problem on Windows7 x64 with
LibreOffice:Version 3.6.2.2 (Build ID: da8c1e6)
Comment 5 Florian Reisinger 2013-04-21 14:58:31 UTC
Please keep in mind, that every distributor has it's own LibreOffice.
Tested on Windows and Ubuntu and it worked --> NOTOURBUG
Comment 6 pcook9 2013-04-22 10:06:11 UTC
(In reply to comment #5)
> Please keep in mind, that every distributor has it's own LibreOffice.
> Tested on Windows and Ubuntu and it worked --> NOTOURBUG

The Libre packages for v3.6.2 on RedHat Enterprise Server 5.8.0.3 and v3.6.2.2 on Win7 x64 were downloaded from libreoffice.org, not bundled with the OS distro.
Comment 7 pcook9 2013-04-22 15:03:54 UTC
I've rebuilt the test environments with Libre v4.0.2.2 and that version opens the file cleanly on Win7 x64 and on Ubuntu 10.04 LTS.
I'll try upgrading the production RedHat Enterprise server from Libre v3.x to Libre v4.
There was a bug in v3.x, it appears to be fixed in Libre v4.  Thanks for that.