Bug Hunting Session
Bug 59787 - Import pdf file containing a music score is a mess
Summary: Import pdf file containing a music score is a mess
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-24 08:43 UTC by riow
Modified: 2016-04-30 22:30 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
sheet music in a protected pdf (72.05 KB, application/pdf)
2013-01-24 08:43 UTC, riow
Details

Note You need to log in before you can comment on or make changes to this bug.
Description riow 2013-01-24 08:43:46 UTC
Created attachment 73551 [details]
sheet music in a protected pdf

A sheet music pdf file is opened in writer, but all scores turn to be a mess.  You can compare it using a pure pdf reader.
Comment 1 Jorendc 2013-01-30 15:09:31 UTC
Thanks for reporting!

When you open a pdf in your LibreOffice Start Center It'll be opened with Draw, not Writer.

I can reproduce this behavior using Mac OSX 10.8.2 LibreOffice Version 4.1.0.0.alpha0+ (Build ID: 53e28cba18bfc1210f119c899e7559e70de360a)
TinderBox: MacOSX-Intel@1-built_no-moz_on_10.6.8, Branch:master, Time: 2013-01-28_23:42:44

Kind regards,
Joren
Comment 2 Jorendc 2013-01-30 15:11:55 UTC
Following [1] I mark this as 'normal medium'.

[1] https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg
Comment 3 QA Administrators 2015-02-19 15:49:56 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.0.3 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-02-19
Comment 4 Jean-Baptiste Faure 2015-02-21 23:32:12 UTC
Perhaps an issue linked to missing fonts. My PDF reader says that this PDF contains non embedded fonts that are not part of the 14 standard PDF fonts.

Best regards. JBF
Comment 5 tommy27 2016-04-16 07:29:05 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.5 or 5.1.2 https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

- Update the version field
- Reply via email (please reply directly on the bug tracker)
- Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-04-16
Comment 6 Jean-Baptiste Faure 2016-04-30 22:30:09 UTC
For me the problem is not on the LO side because the pdf does not provide the required fonts.

Closing as NotOurBug. Please, feel free to reopen if you can provide the missing fonts and show that, even with the correct font, Draw does not render the pdf file correctly.

Best regards. JBF