Download it now!
Bug 59813 - EDITING: Insert picture does not retain directory
Summary: EDITING: Insert picture does not retain directory
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.2.2 release
Hardware: All Windows (All)
: high minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 62177 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-24 17:37 UTC by Paul Webb
Modified: 2015-03-21 11:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Webb 2013-01-24 17:37:02 UTC
Problem description: Insert picture does not retain directory

Steps to reproduce:
1. Insert
2. Picture
3. ....

Current behavior:
Always returns to home directory
Expected behavior:
Should retain previous directory.
              
I create a lot of graphical documents and need to insert a large number of pictures. Having to put in the path every time is a big pain. 
Operating System: Linux (Other)
Version: 3.6.2.2 release
Comment 1 Brenda Granados 2013-02-26 16:41:55 UTC
Hi. I'm trying to understand the issue you are having. What do you mean by doesn't "Should retain previous directory"? Do you mean the images are being moved from their original locations to some other location after being inserted into a document? After I insert an image from some location on my computer, and save and close the document, the image is still there when I reopen. What is happening with your documents? Where do you have to insert a path?

If you can provide any extra information, it would help. I will change this to NEEDINFO, and you can set it back to UNCONFIRMED if you're able to provide some more details.  Thank you.
Comment 2 Paul Webb 2013-02-26 18:16:09 UTC
Hello Brenda

Thanks for replying. I was using 3.6 and am now using 4.0 on Linux Mint 
14 with Cinnamon 1.6.

The problem seems to be that when you are _not_ using the LibreOffice 
file dialogue boxes it reverts to $HOME directory after each picture 
insertion (as well as when you try to open a file actually). When using 
the LibreOffice dialogue boxes it retains the path so you can insert 
several pictures from the same directory. I have switched to using 
LibreOffice dialogue boxes and it is fine. I suspect the problem is 
something to do with gnome/nemo/nautilus rather than LibreOffice.

Best wishes

Paul Webb / Spinnekop

Using Mozilla Thunderbird on Linux Mint 14 Cinnamon.
On 26/02/13 16:41, bugzilla-daemon@freedesktop.org wrote:
> Brenda Granados <mailto:bgran05@gmail.com> changed bug 59813 
> <https://bugs.freedesktop.org/show_bug.cgi?id=59813>
> What 	Removed 	Added
> Status 	UNCONFIRMED 	NEEDINFO
> CC 		bgran05@gmail.com
> Ever confirmed 		1
>
> *Comment # 1 <https://bugs.freedesktop.org/show_bug.cgi?id=59813#c1> 
> on bug 59813 <https://bugs.freedesktop.org/show_bug.cgi?id=59813> from 
> Brenda Granados <mailto:bgran05@gmail.com> *
> Hi. I'm trying to understand the issue you are having. What do you mean by
> doesn't "Should retain previous directory"? Do you mean the images are being
> moved from their original locations to some other location after being inserted
> into a document? After I insert an image from some location on my computer, and
> save and close the document, the image is still there when I reopen. What is
> happening with your documents? Where do you have to insert a path?
>
> If you can provide any extra information, it would help. I will change this to
> NEEDINFO, and you can set it back to UNCONFIRMED if you're able to provide some
> more details.  Thank you.
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>
Comment 3 Jorendc 2013-03-18 07:42:17 UTC
*** Bug 62177 has been marked as a duplicate of this bug. ***
Comment 4 Jorendc 2013-03-18 07:45:41 UTC
I can not reproduce this behavior using Mac OSX 10.8.2 LibreOffice 4.0.2.1 when using the non-LibreOffice dialogs.

But because I found already 2 duplicates, I mark this as NEW.
Comment 5 boicottms 2013-03-18 09:23:24 UTC
Note: I'm the one that wrote bug 62177, that has been marked as duplicated of this.
Today the memorized start brosing directory changed.
When I first submitted the bug, I was working in the A directory and the image browser always started from "documents" folder.
Now I'm working in directory B, and the image browser start from directory A.
Comment 6 Thierry Seewald 2013-06-13 07:52:02 UTC
A friend and I have the same problem on LO 4.0.3 with Win 7.
It works well with ubuntu, but with win7 we're always going to the same directory again. It's not memorizing the last directory used.
I tried LO 4.1 beta 2 too see, but their is the same pb.
How do you change the file dialog box?
Comment 7 Thierry Seewald 2013-06-13 07:59:33 UTC
I found how to change the dialog box, but pretty ugly box on Win7 and before it worked with the standart win box.
Comment 8 Jorendc 2013-06-13 09:58:35 UTC
bug version is oldest version of LibreOffice which the bug is reproducible -> revert change
Comment 9 QA Administrators 2015-03-17 00:04:59 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

    Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
    https://www.libreoffice.org/download/

    If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
  
  If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

    Update the version field
    Reply via email (please reply directly on the bug tracker)
    Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to "inherited from OOo";
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-03-16
Comment 10 boicottms 2015-03-21 11:13:52 UTC
win7/32 LOO Versione: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Versione locale: it_IT