Bug 59828 - Add an ability to use Format Paintbrush multiple times
Summary: Add an ability to use Format Paintbrush multiple times
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:4.1.0
Keywords: needsDevEval
Depends on:
Blocks:
 
Reported: 2013-01-24 23:15 UTC by Mike Kaganski
Modified: 2015-12-18 10:26 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2013-01-24 23:15:44 UTC
When using Style Paintbrush, if one needs to apply the same formatting to multiple incontiguous pieces of text, the Style Paintbrush button needs to be pushed repeatedly. This distracts from the process.

It would be great if one could, say, push the Style Paintbrush while holding a special key (say, Alt), and then this button would become "toggle button", thus operation would continue until another press to that button. After the initial "Alt+press", one could release the Alt and use the normal clicks, Ctrl+clicks or Shift+Ctrl+clicks multiple times to apply the original format.
Comment 1 Phil 2013-02-13 23:41:34 UTC
From the online help: "If you want to apply the formatting to more than one selection, double-click the Format Paintbrush Icon. After you apply all the formatting, click the icon again."

Great when you know how. Maybe the Icon tooltip could be modified:

Paintbrush Icon
(double-click for multi-selection)
Comment 2 Mike Kaganski 2013-02-14 07:32:21 UTC
(In reply to comment #1)
Thank you Phil!

I know that this is not a proper place for support requests; and I'm sorry that my issue turned out to be my own ignorance. I was absolutely sure I've already tried everything.

If everything else fails, RTFM :)
Excuse me for noise.
Comment 3 Joel Madero 2013-02-19 22:19:47 UTC
I think the additional label content could work. I'll take a look and see how long the string becomes (if it's too long probably will avoid it) 

Marking as:

New (confirmed)
Enhancement (not a bug)
Low (just a label, no additional feature really)

ProposedEasyHack
Comment 4 Björn Michaelsen 2013-02-24 18:18:18 UTC
Approving, CC'ing Astron on the bug as this is AFAIK inconsistent with our other UI -- should we bother that?
Comment 5 Not Assigned 2013-02-24 18:23:05 UTC
Joel Madero committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dcff3305fa43388a0285d05be6da84ea7daa49fe

fdo#59828 update Format Paintbrush Label



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Stefan Knorr (astron) 2013-02-24 22:24:35 UTC
Hi all,

right, it's inconsistent, not really in a bad way – though, if you could add similar information to the drawing toolbar buttons (and any other buttons that can be double-clicked to use a variation of the same functionality) that would be great. (When double-clicking the drawing toolbar buttons, you can create multiples of the same shape without having to click the button each time.)


Slightly OT... We already have an "extended tooltips" option where this particular information would seem to fit better. On https://wiki.documentfoundation.org/Whiteboards/KillOptions#General , I wrote down some ideas to improve these extended tips...
Comment 7 Joel Madero 2013-02-25 04:33:48 UTC
ah I didn't know about extended tool tips. Let me dig into that a bit and see what I can find. 

So for now we'll discard the patch I submitted and I'll check into the alternative?
Comment 8 Stefan Knorr (astron) 2013-02-25 08:05:11 UTC
Not necessarily – that is, only if you want all the extra work with making the extended tips viable. Otherwise, it would probably be better to just add similar "double-click me" text to other toolbar functions for consistency.
Comment 9 Joel Madero 2013-02-25 15:02:44 UTC
Okay let's go with that - "a lot of extra work" scared me off ;) 

Where should I go to get a list of what else has double click features? Manual? Docs team?
Comment 10 Stefan Knorr (astron) 2013-02-25 21:51:49 UTC
I guess the doc team is a good place to go.

The only place where I know double clicking works is in the drawing toolbar of Impress/Draw.
Comment 11 QA Administrators 2013-07-18 19:20:32 UTC
Unfortunately I just haven't had the time to solve this bug - if I make any progress I will report back but until then setting back to default and NEW
Comment 12 Joel Madero 2014-02-27 23:29:47 UTC
In order to limit the confusion between ProposedEasyHack and EasyHack and to make queries much easier we are changing ProposedEasyHack to NeedsDevEval.

Thank you and apologies for the noise
Comment 13 Mike Kaganski 2015-04-28 09:19:26 UTC
Ok, it turns out that the tooltip had been augmented
(already in Version: 4.1.0.0.beta1
Build ID: 5271b34bec742e190e2fe5a7dadb7334a705b54):
"... (double click for multi-selection)"

Closing as WORKSFORME
Thank you!
Comment 14 Robinson Tryon (qubit) 2015-12-18 10:26:52 UTC
Migrating Whiteboard tags to Keywords: (needsDevEval)
[NinjaEdit]