Bug Hunting Session
Bug 59852 - Calc will not print worksheets
Summary: Calc will not print worksheets
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.2 rc
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-25 15:20 UTC by TJ
Modified: 2015-03-08 18:07 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
CALC file that will not print, preview, or export to pdf correctly (14.79 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-01-27 15:41 UTC, TJ
Details

Note You need to log in before you can comment on or make changes to this bug.
Description TJ 2013-01-25 15:20:28 UTC
I have tried to print a worksheet from Calc 4.0.0.1 rc and 4.0.0.2 rc and it will not print.  Using the selected work sheet option.  The print preview is blank.

If I select all sheets, it will preview the first worksheet and only print it.

I was able to print the work sheet using the selected cells option.

Page pre view is also blank.

Also, export directly as a PDF does not work.  With the second of 12 worksheets open, when I select the export PDF option, it will only export the first worksheet.

I have looked at writer and its print and print preview functions work normal.  

Thanks for a great program.
Comment 1 Jorendc 2013-01-26 18:58:22 UTC
Is it possible to attach your calc sheet so we can try to reproduce?

If it's confidential, please feel free to email the document to me. I only would like to try to reproduce this behavior. If I can reproduce we also can consider to share this document with interested developers.

Thanks in advance,
Joren
Comment 2 TJ 2013-01-27 15:41:02 UTC
Created attachment 73737 [details]
CALC file that will not print, preview, or export to pdf correctly

When I try to preview the 2nd, 3rd, or 4th worksheet, it will not preview or print.  The 1st and last worksheet will preview and print.
Comment 3 Jorendc 2013-01-27 16:43:38 UTC
Thanks for your time providing us the necessary information!

With attached document I can reproduce this behavior. When I export it as PDF, only the first and last sheet is exported. When clicking 'Print Preview' on the second to second-last sheet, no preview is shown.
Tested with Mac OSX 10.8.2 and LibreOffice 4.0.0.2 rc2 (Bouw-id: 408fe71bd18616c467b3dcd7ab6756528ffcae2)
TinderBox: MacOSX TDF Release, Branch:libreoffice-4-0, Time: 2013-01-22_15:37:59

Following [1] I mark this bug as 'major high' because this bug doens't resolve to print *any* document or resolve in data loss/crash etc. Otherwise this is a serious glitch (inability to print *some* (not any/all) data).

1: https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg

Kind regards,
Joren
Comment 4 QA Administrators 2015-02-19 15:47:58 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.0.3 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-02-19
Comment 5 Buovjaga 2015-03-08 18:07:05 UTC
Format - Print ranges - Edit: Print range was set to none for the problematic sheets mentioned. Clearing the print ranges solves the problem.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI