Bug 59905 - EDITING: DSUM Parameter List - unreasonable error
Summary: EDITING: DSUM Parameter List - unreasonable error
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-26 14:37 UTC by Dereck Wonnacott
Modified: 2015-08-01 07:08 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Error Sample (11.88 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-06-05 14:24 UTC, Dereck Wonnacott
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dereck Wonnacott 2013-01-26 14:37:37 UTC
Problem description: 
if you use the DSUM function with a parameter list that is wider than the number of parameters (if you have extra unused columns in your parameter range) the formula generates an err:504.


Steps to reproduce:
1. Make a DSUM forumula per usual 
2. expand the parameter region to include one extra unused column

Current behavior:
generates error


Expected behavior:
It should ignore the extra column. 

Other info:
Google Docs works as expected.

              
Operating System: Ubuntu
Version: 3.6.2.2 release
Comment 1 Joel Madero 2013-05-29 20:04:15 UTC
Please attach a document showing the behavior.

Marking as NEEDINFO - once you attach document mark as UNCONFIRMED and we will triage it
Comment 2 Dereck Wonnacott 2013-06-05 14:24:23 UTC
Created attachment 80349 [details]
Error Sample

Here is the sample file for the bug. 

You will notice that I have two DSUM formulas, the first one has an extra column and generates an error, the second one does not have an extra column and works fine.
Comment 3 Joel Madero 2013-06-05 16:58:13 UTC
Thanks for the additional info, changing version back as version reflects earliest confirmed version with the issue, we just use comments to say that it still exists on a newer release.

Thanks again
Comment 4 Joel Madero 2013-09-24 21:40:19 UTC
This is not a bug, from reading documentation we're following standards. I've never used DSUM before but I see that the issue is that if you include column N you have nothing to match O8 to because it's blank so it's spitting out errors. The error goes away if you remove one of the headers for your table (for instance delete D6, then you have blank=blank so it's matching up). From what I can tell this is all correct, if you know of documentation that this is wrong or if you know of software that behaves differently please let me know and I'll re-investigate.
Comment 5 Dereck Wonnacott 2013-10-14 14:26:23 UTC
Google Docs and Microsoft Excel both work with empty columns.


“The greater danger for most of us lies not in setting our aim too high and
falling short; but in setting our aim too low, and achieving our mark.” -
Michelangelo


On Tue, Sep 24, 2013 at 5:40 PM, <bugzilla-daemon@freedesktop.org> wrote:

>  Joel Madero <jmadero.dev@gmail.com> changed bug 59905<https://bugs.freedesktop.org/show_bug.cgi?id=59905>
>  What Removed Added  Status UNCONFIRMED RESOLVED  Resolution --- NOTABUG
>
>  *Comment # 4 <https://bugs.freedesktop.org/show_bug.cgi?id=59905#c4> on bug
> 59905 <https://bugs.freedesktop.org/show_bug.cgi?id=59905> from Joel
> Madero <jmadero.dev@gmail.com> *
>
> This is not a bug, from reading documentation we're following standards. I've
> never used DSUM before but I see that the issue is that if you include column N
> you have nothing to match O8 to because it's blank so it's spitting out errors.
> The error goes away if you remove one of the headers for your table (for
> instance delete D6, then you have blank=blank so it's matching up). From what I
> can tell this is all correct, if you know of documentation that this is wrong
> or if you know of software that behaves differently please let me know and I'll
> re-investigate.
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 6 Joel Madero 2013-10-14 14:37:45 UTC
In the future please don't respond via email as it just ads clutter to bug comments (similar with extra quotes that don't add to the issue at hand). I'll mark this back to UNCONFIRMED and investigate a bit
Comment 7 Dereck Wonnacott 2013-10-14 14:40:24 UTC
My bad, sorry about the garbage. :/
Comment 8 Joel Madero 2013-10-14 14:43:02 UTC
No worries, we're trying to get our bug tracker to explicitly say "don't respond via email" but as of now it's just a hidden request by QA that we try to include to avoid comments becoming incomprehensible- not your fault at all. (Also my mistake for saying "ad" instead of "add").
Comment 9 Drew 2013-12-12 21:44:02 UTC
Cannot change font in headers on the LibreOffice spreadsheets.
Comment 10 Joel Madero 2013-12-13 17:02:05 UTC
@Drew - how is that related to this bug? Also please don't change the priorities without knowing our workflow - thanks!
Comment 11 QA Administrators 2015-04-19 03:20:16 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-18
Comment 12 Buovjaga 2015-06-15 11:10:35 UTC
Drew set this to NEW without any reason.
Comment 13 Alex Thurgood 2015-06-15 12:55:46 UTC
So the question of whether or not this is a bug comes down to whether or not we are supposed to mimick the behaviour of Excel and Google Sheets ?
Comment 14 Jean-Baptiste Faure 2015-08-01 07:08:28 UTC
If you modify the formula in I8 to =DSUM($B$6:$G$30;$E$6;J8:O9) it does not return an error anymore because G6 is empty. The problem is to know where is the error, did you forgot the column G in the database range, or did you add an erroneously empty search criteria?

I tend to prefer clear error message than trying to interpret user typing errors.
empty/empty is a valid search criteria. If you do not have an empty header in you database range, it is not the role of Calc to decide if you made an error in the database range, in the search criteria or elsewhere.

So closing as NotABug. Feel free to reopen if you disagree. In such a case please argue.

Best regards. JBF