Bug Hunting Session
Bug 59943 - error message / dialog window after LO crash won't disappear
Summary: error message / dialog window after LO crash won't disappear
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: Other Mac OS X (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 67570 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-27 21:02 UTC by Jo Raabe
Modified: 2015-04-19 17:22 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the dialogue window (121.49 KB, image/png)
2013-01-27 21:02 UTC, Jo Raabe
Details
error_video (832.94 KB, video/mp4)
2013-07-31 08:08 UTC, retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jo Raabe 2013-01-27 21:02:42 UTC
Created attachment 73741 [details]
Screenshot of the dialogue window

Problem description: 

After LibreOffice was shut down (something went wrong) earlier today, everytime it opens, a dialog window shows up. It says (Translatet from norwegian to english)

"The last time you opened LibreOffice, the program closed unexpected while opening windows. Would you like to open the windows again!

...


"Do not open again"                               "Open Again""

The problem is that it's impossible to press either of the two buttons. The dialogue windows also do not have a red dot to close it down. The only way to close it down is to force the whole of Libreoffice to close. 

The program seems to work OK under the window. I can still open documents, but the dialogue window won't go away. 

I've tried to restart my computer, and even tried to re-install LibreOffice, but it still doesn't help. Do you have any advice?

Steps to reproduce:
Sorry, not able do give you these, have never experienced this before

Current behavior:
I can't close the dialogue window

Expected behavior:
That the window doesn't show up

              
Operating System: Mac OS X
Version: 3.6.4.3 release
Comment 1 Emir Sarı (away) 2013-01-30 19:42:50 UTC
(In reply to comment #0)
> 
> I've tried to restart my computer, and even tried to re-install LibreOffice,
> but it still doesn't help. Do you have any advice?

>               
> Operating System: Mac OS X
> Version: 3.6.4.3 release

Have you tried resetting your user profile after reinstalling Libreoffice?

If the dialogue goes away after resetting your profile, could you profile us a sample file that this problem occurs with?

And lastly what is your OS X version?
Comment 2 Jo Raabe 2013-01-31 16:54:57 UTC
Hello!

Thanks for answering!

I've solved my problem by following the instructions on this site.

http://www.techpository.com/?page_id=813

I don't know if that is resetting my profile.

I don't fully understand what you mean by a sample file. It happened all the time I opened LibreOffice, even when I didn't open a file.

I run OSX 10.8.2

Regards

Jo Raabe

30. jan. 2013 kl. 20:42 skrev bugzilla-daemon@freedesktop.org:

> Emir Sarı changed bug 59943 
> What	Removed	Added
> Status	UNCONFIRMED	NEEDINFO
> Ever confirmed	  	1
> 
> Comment # 1 on bug 59943 from Emir Sarı
> (In reply to comment #0)
> > 
> > I've tried to restart my computer, and even tried to re-install LibreOffice,
> > but it still doesn't help. Do you have any advice?
> 
> >               
> > Operating System: Mac OS X
> > Version: 3.6.4.3 release
> 
> Have you tried resetting your user profile after reinstalling Libreoffice?
> 
> If the dialogue goes away after resetting your profile, could you profile us a
> sample file that this problem occurs with?
> 
> And lastly what is your OS X version?
> 
> You are receiving this mail because:
> You reported the bug.
Comment 3 retired 2013-07-31 08:06:11 UTC
*** Bug 67570 has been marked as a duplicate of this bug. ***
Comment 4 retired 2013-07-31 08:07:49 UTC
Setting to NEW. This is still a big problem in LO 4.1.0.4 on OS X 10.8.4 and very frustrating to the user.

Problem description: After crash error message from LO does not disappear, no matter which of the two options available the user chooses.

Steps to reproduce:
1. Open the following document with LO 4.1.0.4 on OS X 10.8.4 -> Crash.
https://bugs.freedesktop.org/attachment.cgi?id=83317
(from bug https://bugs.freedesktop.org/show_bug.cgi?id=67554)
2. When LO is started again an error message is shown. Loose translation: LO was closed unexpectedly while opening a window. Do you want to try to re-open that window? (bold) If you've selected to not re-open windows, you might have to open and position the window yourself (normal). Option left: don't re-open Option right: re-open
3. no matter what is selected, the error message won't disappear.

Current behavior: Error message sticks and won't disappear.

Expected behavior: Follow the user choice and close error msg.

See attached video showing the behavior.
Comment 5 retired 2013-07-31 08:08:25 UTC
Created attachment 83349 [details]
error_video
Comment 6 retired 2013-07-31 08:18:55 UTC
Resetting the user profile does not make this error msg disappear.
Comment 7 retired 2013-07-31 11:23:25 UTC
Also, when opening files associated with LO, those files won't get opened. All the user sees is the LO startcenter and the dialogue window. Since that is crippling usability rather badly I'm raising importance to "high".
Comment 8 QA Administrators 2015-04-19 03:21:59 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-18
Comment 9 steve -_- 2015-04-19 17:22:11 UTC
This got imo fixed somewhere in the LO 4.x releases. Setting to WFM.

Jo: If the issue persists for you using LO 4.4.x please re-open this bug.