Bug Hunting Session
Bug 59950 - VIEWING: pie chart data label not shown for a 0-value
Summary: VIEWING: pie chart data label not shown for a 0-value
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-28 02:21 UTC by bugquestcontri
Modified: 2015-02-25 16:57 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
odp-file with 1 example slide and information (62.24 KB, application/vnd.oasis.opendocument.presentation)
2013-01-28 02:21 UTC, bugquestcontri
Details
Sample document (13.89 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-01-28 07:16 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugquestcontri 2013-01-28 02:21:18 UTC
Created attachment 73749 [details]
odp-file with 1 example slide and information

Problem description:
I created a pie chart based on 5 different data points. 1 data point has the value of zero.

The legend does not show the label for the 0-value category.

If the zero value is not shown, the reader of the pie chart will not understand the full story behind the data and will ask why in the attached example, the data point "much higher" is missing. 

Steps to reproduce:
1. create a pie chart with one data point has a 0-value
2. format pie chart that the category is shown
3. result the 0-value category is not 

Current behavior: category for 0-value data points are not shown

Expected behavior: category for 0-value data points being shown

I can be contacted
Operating System: Windows XP
Version: 3.6.4.3 release
Comment 1 Rainer Bielefeld Retired 2013-01-28 07:14:49 UTC
Has nothing to do with Presentation, effect also [Reproducible] in Spreadsheetwith "LibO  4.0.0.2 rc   -  GERMAN UI / German Locale  [Build ID: 5991f37846fc3763493029c4958b57282c2597e)]"  {tinderbox: @6, pull time 2013-01-24  07:20(?)} on German WIN7 Home Premium (64bit) with User Profile automatically created form renamed /3 User profile used by 3.6.5.2

Inherited from OOo, already in OOo 3.1.1

I first saw this one as an Enhancement request, but I saw that working with OOo 2.0.3, there also legend symbol, label and value for a 0-Value are shown. When I open a sample spreadsheet with 0-value in pie chart from LiobO, after a double click info for 0 value appears at pie chart.

Same with LibO 3.5.4.2 on Ubuntu 12 (VirtualBox)
@Spreadsheet Team:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug or forward the Bug if it's not your turf (and remove others in team from CC).
Comment 2 Rainer Bielefeld Retired 2013-01-28 07:16:17 UTC
Created attachment 73758 [details]
Sample document

Simply play with the values in the table. When one becomes set to 0, expectedly the sector is no longer visible, but unexpectedly the data label disappears.
Comment 3 QA Administrators 2015-02-19 15:37:47 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.0.3 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-02-19
Comment 4 Jean-Baptiste Faure 2015-02-22 09:28:11 UTC
(In reply to Rainer Bielefeld Retired from comment #2)
> Created attachment 73758 [details]
> Sample document
> 
> Simply play with the values in the table. When one becomes set to 0,
> expectedly the sector is no longer visible, but unexpectedly the data label
> disappears.

Opening this file with LibreOffice 4.4.2.0.0+ shows the label b in the legend even if the corresponding data is zero.

Closing as WorksForMe. Please, feel free to reopen if you disagree.

Best regards. JBF
Comment 5 bugquestcontri 2015-02-25 16:57:41 UTC
Great news. I am looking forward to version 4.4.2