Bug Hunting Session
Bug 59997 - FORMATTING Dates in Calc
Summary: FORMATTING Dates in Calc
Status: RESOLVED DUPLICATE of bug 40685
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.2 rc
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-29 01:38 UTC by Victor
Modified: 2017-10-09 20:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Victor 2013-01-29 01:38:23 UTC
Hi. I need to show a date in the same cell, in two lines, and centered.
Centered is not possible.
Example:
|-----------|
|  january  |
| monday 28 |
|-----------|

Look what happens in this video:

https://docs.google.com/file/d/0B3va26fKWcqKcmd2MUtBcmNLNUU/edit

Thank you

Victor
Comment 1 m.a.riosv 2013-01-30 02:16:01 UTC
Hi Victor, thanks for reporting,

Reproducible with:
Win7x64 Ultimate
Version 4.0.0.2 (Build ID: 5991f37846fc3763493029c4958b57282c2597e)

In one cell enter a date: 28/1/2013
Format the cell:
Number: DDDD DD MMMM
Alignment: Horizontal= Center, Enable Wrap text automatically.
 
Seems that the row height is calculated, but the cell only shows ###.
Comment 2 Daniel Bankston 2013-02-05 07:20:20 UTC
Hi, Victor, I think the video was a nice touch to demonstrate your issue.

If I understand correctly, I think this is maybe more of an enhancement request and not a bug because the user is able to center the date by selecting Align Center Horizontally.  The user just can't center separate parts of the date on separate lines within the same cell.
Comment 3 Kohei Yoshida 2013-02-06 03:49:13 UTC
Yup, this is an enhancement request.

This is a known limitation, and is not a bug.  It would be extremely difficult to handle wrapping of date values since date values themselves are numeric values internally, and we don't wrap numeric values in cells.
Comment 4 Laurent BP 2017-06-03 20:07:12 UTC
Workaround: use TEXT( date ; format ) to convert your date in a string which could be wrapped and centered
Comment 5 Laurent BP 2017-10-09 20:57:04 UTC

*** This bug has been marked as a duplicate of bug 40685 ***