Bug Hunting Session
Bug 60080 - Metafile images cause slowness/freezes
Summary: Metafile images cause slowness/freezes
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-30 17:49 UTC by Paolo Devoti
Modified: 2015-02-22 10:34 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
sample file where behaviour is happening (432.00 KB, application/vnd.ms-powerpoint)
2013-01-30 17:49 UTC, Paolo Devoti
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paolo Devoti 2013-01-30 17:49:04 UTC
Created attachment 73939 [details]
sample file where behaviour is happening

While the presentation opens without troubles slides 9 and 19 of attached file are taking almost a minute to show up and the application is frozen during that time.
It does not happen in slideshow mode. To see the effect click on miniature 8 or 18 on the left then key pgdwn. 
PC is a core i7 and win7-64 so is not a pc performance matter.
Comment 1 Jorendc 2013-01-30 19:31:20 UTC
Thanks for reporting!

I can reproduce this problem using LibreOffice 4.0.0.2 rc2; but I can reproduce it also using PowerPoint ... So I think the ppt file is corrupt and it's not a LibreOffice bug. I tested it with Mac OSX 10.8.2 (and using PowerPoint for Mac 2011)

Can you verify this behavior by using PowerPoint (Microsoft Office) (if you have no PowerPoint, I thought there was a free PowerPoint viewer distributed by Microsoft)?

I mark this bug as 'NEEDINFO'.

Kind regards,
Joren
Comment 2 Paolo Devoti 2013-01-31 10:29:09 UTC
Tested with MS Office 97 on Windows XP and there are no delays
Comment 3 Jorendc 2013-01-31 17:29:33 UTC
(In reply to comment #2)
> Tested with MS Office 97 on Windows XP and there are no delays

Ok, thanks for testing that! But I still can't confirm 'good behavior' even using latest version of MS Office (for Mac).

But, with my other system (Linux Mint 14 x64) with a better CPU, the document loads a lot faster. The images on slide 9 result in a freeze (using this system 15 seconds, using my MacBook pro 30 seconds). When I select slide 10 (just some text) I don't have any problem (and 'toggling' between slide 10 and 13 (=also slide with just text) goes fast as well). But when you click on slide 9 or slide 12 it result back in a freeze/slowness. 

Therefore I mark this bug as valid and changed the topic a bit.

Following [1] I mark this bug as 'Major high'.

Kind regards,
Joren

[1] https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg
Comment 4 QA Administrators 2015-02-19 15:49:02 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.0.3 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-02-19
Comment 5 Jean-Baptiste Faure 2015-02-22 10:34:08 UTC
I tried the attached file with LibreOffice 4.4.2.0.0+ built at home under Ubuntu 14.10. Indeed there is a delay before slides 9 and 19 are completely shown but this delay is only a few seconds and the application does not freeze. Same behavior with LO 4.3 and LO 4.2.

So closing as WorksForMe. Please feel free to reopen if you disagree.

Best regards. JBF