Download it now!
Bug 60108 - ASKLIBREOFFICE: Uploading avatar in Ask LibreOffice fails
Summary: ASKLIBREOFFICE: Uploading avatar in Ask LibreOffice fails
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: WWW (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on: 61098
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-31 08:02 UTC by Mikko Ahlroth
Modified: 2014-02-12 08:13 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mikko Ahlroth 2013-01-31 08:02:20 UTC
Problem description: 
This is related to the question at
http://ask.libreoffice.org/en/question/10200/meta-how-to-upload-avatar-image-on-asklibo/

I seem to be unable to upload an avatar image in Ask
LibreOffice. I have tried the latest Chrome on both OS X
(1.6.8) and Windows 7 and also Firefox 12 on OS X. Uploading
always fails with the error "Upload a valid image. The file you
uploaded was either not an image or a corrupted image." I
sometimes also get an internal server error. There is a
screenshot of that in the thread linked above.

Steps to reproduce:
1. Upload an avatar
2. See error

Current behavior:
Error

Expected behavior:
New avatar uploaded.

Operating System: All
Version: unspecified
Comment 1 Jorendc 2013-02-07 00:12:49 UTC
Thanks for reporting! I can reproduce this error when I try to upload an avatar.
Comment 2 Robinson Tryon (qubit) 2013-02-07 11:49:59 UTC
(Testing in FF 18.0.2 on Ubuntu 12.04.2)

I already have an avatar picture uploaded, so I tried uploading a new picture.


Trying to re-upload the same picture I originally uploaded (421KB JPEG), I get the following:

---
You haven't uploaded an avatar yet. Please upload one now.

    Upload a valid image. The file you uploaded was either not an image or a corrupted image.
---

There are two problems here

1. I *have* uploaded an avatar image, so the system is confused/wrong.

2. The image is valid (it was uploaded previously and is in use on my profile right now)

Trying with a 4MB PNG file, I get the same error as with the JPG.

Trying with a 2MB GIF file, I get a different error:

---
    Your file is too big (2.0 MB), the maximum allowed size is 1.0 MB
---

(Not sure why the 4MB PNG file didn't trigger that error)

Trying with a 513.4KB GIF file, I get the following:

---
Internal server error
system error log is recorded, error will be fixed as soon as possible
please report the error to the site administrators if you wish 
---
Comment 3 Robinson Tryon (qubit) 2013-02-08 22:47:16 UTC
Note: Alex will be updating the Askbot software soon. Hopefully the update will solve this problem; if the update does not solve the problem, we'll tackle it next.
Comment 4 Robinson Tryon (qubit) 2013-03-21 08:56:52 UTC
I've had two pings about this problem in the last day, so I just wanted to give everyone an update.

We're still waiting on the Askbot software to be upgraded (bug 61098). When that upgrade is complete, we'll check to see if this bug is still present. If the upload problems have not been solved, I'll do my best to try to get the infrastructure folks to look at this bug as quickly as possible.
Comment 5 Daniel Hornung 2013-07-12 16:46:38 UTC
Said updating bug report is marked as fixed, so it may be time to look into this one again as well.
Comment 6 Robinson Tryon (qubit) 2013-07-14 19:05:09 UTC
(FF 22 on Ubuntu 12.04.2)

Trying to upload a new avatar picture, I encounter problems.

1) The interface tells me that I have not yet uploaded an avatar picture (which is obviously false)

"You haven't uploaded an avatar yet. Please upload one now."

2) If I try to upload/change my picture, I get the following error message:

"Upload a valid image. The file you uploaded was either not an image or a corrupted image."


The image I'm using to test is just a flip of my current profile image (using ImageMagick) -- it doesn't appear as 'corrupt' on my system.

tl;dr --> Still a problem in our install of Askbot. Perhaps something to do with our data/database?
Comment 7 Evgeny Fadeev 2014-02-11 01:22:11 UTC
I've tried to upload an image, worked for me.

Is this still a problem?
Comment 8 Mikko Ahlroth 2014-02-12 08:13:16 UTC
I was also able to upload a PNG avatar when I just tried, so it seems this is resolved.