Bug 60156 - FILEOPEN: crash when loading a presentation
Summary: FILEOPEN: crash when loading a presentation
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-02-01 12:40 UTC by Bruno Cornec
Modified: 2013-03-26 18:15 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example presentation crashing X (2.00 MB, application/vnd.oasis.opendocument.presentation)
2013-02-01 12:40 UTC, Bruno Cornec
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bruno Cornec 2013-02-01 12:40:58 UTC
Created attachment 74046 [details]
Example presentation crashing X

Problem description: 

I've upgraded my laptop from Mandriva 2010.2 to Mageia 2 and since I have problems with Impress, I didn't had for years. The move was then from openOffice.org 3.2.1 to LibreOffice 3.5.5 or upstream 3.6.4.3 which exhibits the same issue

Steps to reproduce:
1. /opt/libreoffice3.6/program/soffice presentation.odp
2. depending on the pres, X crashing or just libreoffice crashing


Attached is a first presentation which is crashing X. I can provide others if this is not sufficient all produced with the 3.2.1 version of openoffice.org

On some presentation, they load, and LO crashes when trying to scroll through the slides (seems some backgroud picture is causing the pb, but it's difficult to be sure.
Operating System: Linux (Other)
Version: 3.6.4.3 release
Last worked in: Master old  -3.6
Comment 1 Jorendc 2013-02-01 13:05:40 UTC
Can't reproduce, using LibreOffice 4.0.0.2 rc2 with Linux Mint 14 x64.

I'm not convinced this will resolve the problem, but is it possible to reset your User Profile following https://wiki.documentfoundation.org/UserProfile#Resetting_the_user_profile ?

Thanks for testing,
Joren
Comment 2 Gerry 2013-02-01 23:11:22 UTC
Can't reproduce. Tested on 4.0rc2 and version 3.6.2.2 on Ubuntu 12.10. All is fine here.
Comment 3 Julien Nabet 2013-02-02 09:53:51 UTC
Bruno:
did you install any specific LO extensions? If yes could, you disable then and try again?
did you install any specific fonts? Could you uninstall these for the test?
what's your Java version?

Could you try to retrieve a backtrace? (see https://wiki.documentfoundation.org/Bug_Report#How_to_get_a_backtrace_.28on_Linux.29)
Comment 4 Michael Meeks 2013-03-26 16:07:30 UTC
Hi Bruno,

Thanks for filing - sadly, it's not reproducible here either; at least with 4.0 and 4.1 (master). Clearly if the X server is crashing - then at least one part of the bug is not in LibreOffice - X should never crash with a bad client.

I appreciate the problems debugging that :-) if you have a moment to launch gdb from a remote ssh sometime and attach it to libreoffice and/or X - while loading that slideshow, it'd be great to get a trace; in the meantime closing notourbug.

Hope all's well at HP otherwise :-)

Thanks !
Comment 5 Bruno Cornec 2013-03-26 18:15:12 UTC
Sorry to come back late o that. Indeed it seems I've not been able to reproduce this problem using 4.0 upstream that I downloaded following suggestions in the bug report. As I'm migrating more and more to that version I'l lsee whether older pres are opening without issue, and will potentially reopen with more debugging info if that happens again.

Thanks for al lyour support !