Bug 60186 - FILTER: The active filter column is not highlighted
Summary: FILTER: The active filter column is not highlighted
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: needsUXEval
Depends on:
Blocks: AutoFilter
  Show dependency treegraph
 
Reported: 2013-02-02 13:01 UTC by yuzejya
Modified: 2021-04-06 16:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description yuzejya 2013-02-02 13:01:27 UTC
Problem description: 

Steps to reproduce:
1. choose a row and apply a filter
2. the filter is successfully applied and one can sort and select the sub-items of all columns

Current behavior:
After selecting a sort on a column, there is no change in the filter indicator. all filter indicators (the arrows next to the column header) look alike.

Expected behavior:
After selecting a sort on a column, that filter indicator would change to an arrow with a darker/lighter color. If sort is selected, an additional up/down arrow may appear to indicate the choice.

Thanks for listening!
Cheers, M
Operating System: Windows 7
Version: 3.6.4.3 release
Comment 1 Jorendc 2013-02-06 22:46:55 UTC
Hi,

Thanks for reporting!
Is it possible to explain to us what you mean with 'apply a filter' (which menu, right click?)

Kind regards,
Joren
Comment 2 yuzejya 2013-02-07 07:29:49 UTC
Hi Joren,

in a sheet where one has more columns each with a header (a specific cell
used for naming the column), do the following:
- select the row with the headers
- go to Data > Filter... > Autofilter
- one can now sort the sheet using each column

The action itself is OK (everything is sorted OK), but any sign (or colour
change) is missing which column is/was sorted.

Cheers,
M


On Wed, Feb 6, 2013 at 11:46 PM, <bugzilla-daemon@freedesktop.org> wrote:

>  Jorendc <joren.libreoffice@telenet.be> changed bug 60186<https://bugs.freedesktop.org/show_bug.cgi?id=60186>
>  What Removed Added  CC   joren.libreoffice@telenet.be
>
>  *Comment # 1 <https://bugs.freedesktop.org/show_bug.cgi?id=60186#c1> on bug
> 60186 <https://bugs.freedesktop.org/show_bug.cgi?id=60186> from Jorendc<joren.libreoffice@telenet.be>
> *
>
> Hi,
>
> Thanks for reporting!
> Is it possible to explain to us what you mean with 'apply a filter' (which
> menu, right click?)
>
> Kind regards,
> Joren
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 3 Jorendc 2013-02-07 11:53:56 UTC
(In reply to comment #2)
> in a sheet where one has more columns each with a header (a specific cell
> used for naming the column), do the following:

Oh ok, thanks for this explanation :-). I can confirm this, using LibreOffice 4.0.0.3 rc3 with Linux Mint 14 x64.
 
> The action itself is OK (everything is sorted OK), but any sign (or colour
> change) is missing which column is/was sorted.

Because this is more an enhancement request and not 'bad behavior'. I mark this as an enhancement request and set status to NEW.

Thanks for reporting, help and time!
Kind regards,
Joren
Comment 4 yuzejya 2013-02-07 18:04:57 UTC
Dear Joren,

whe reporting, I've seen only an option for a bug report. I see that it is
like to be defined as an enhancement.

Cheers
M


On Thu, Feb 7, 2013 at 12:53 PM, <bugzilla-daemon@freedesktop.org> wrote:

>  Jorendc <joren.libreoffice@telenet.be> changed bug 60186<https://bugs.freedesktop.org/show_bug.cgi?id=60186>
>  What Removed Added  Hardware Other All  OS Windows (All) All  Status UNCONFIRMED
> NEW  Severity normal enhancement  QA Contact
> joren.libreoffice@telenet.be  Ever confirmed   1
>
>  *Comment # 3 <https://bugs.freedesktop.org/show_bug.cgi?id=60186#c3> on bug
> 60186 <https://bugs.freedesktop.org/show_bug.cgi?id=60186> from Jorendc<joren.libreoffice@telenet.be>
> *
>
> (In reply to comment #2 <https://bugs.freedesktop.org/show_bug.cgi?id=60186#c2>)
> > in a sheet where one has more columns each with a header (a specific cell
> > used for naming the column), do the following:
>
>
> Oh ok, thanks for this explanation :-). I can confirm this, using LibreOffice
> 4.0.0.3 rc3 with Linux Mint 14 x64.
>
> > The action itself is OK (everything is sorted OK), but any sign (or colour
> > change) is missing which column is/was sorted.
>
>
> Because this is more an enhancement request and not 'bad behavior'. I mark this
> as an enhancement request and set status to NEW.
>
> Thanks for reporting, help and time!
> Kind regards,
> Joren
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 5 b. 2020-09-13 14:37:14 UTC
as of now - LO 7.1 on win7x64 - i haven't had this bug since years, 

the 'filtered indicator' appear, i have never seen a 'sort indicator', has someone else? 

could someone make a recheck with linux ver.? thanks,
Comment 6 NISZ LibreOffice Team 2021-03-25 16:10:55 UTC
(In reply to b. from comment #5)
> as of now - LO 7.1 on win7x64 - i haven't had this bug since years, 
> 
> the 'filtered indicator' appear, i have never seen a 'sort indicator', has
> someone else? 
> 
> could someone make a recheck with linux ver.? thanks,

This still happens, although I'm not sure this is actually worth any work. Data is just data.

What OP meant is that after you add an autofilter, its menu has Sort Ascending and Sort Descending options, which work fine but you have no visual indication that they were used.

Now, I would argue against adding anything (like changing the menu items to have a checkmark if selected) since these are use once features: if you sort the filtered data and add a new row below, its value appears in the Autofilter (its range is auto-extended) but the new row does not get sorted instantly - you have to select a sort option from the Autofilter dropdown again to place the new row into the sorted series.

Adding UX team for opinions.

I think above behavior is fine.

Cheers
Gabor
Comment 7 Heiko Tietze 2021-04-06 16:27:59 UTC
(In reply to NISZ LibreOffice Team from comment #6)
> the new row does not get sorted instantly

Exactly this would be required when we use a checkbox- or we uncheck when data is modified (also not good UX). And if the request is only about feedback, whether sorting is up or down, I believe the data are good enough.