Download it now!
Bug 60189 - EDITING: Copy from Microsoft Excel copies all styles across (should filter out)
Summary: EDITING: Copy from Microsoft Excel copies all styles across (should filter out)
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.7.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-02 15:10 UTC by john.pratt
Modified: 2015-03-15 16:38 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Excel document causing the problem (24.14 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2013-02-02 15:10 UTC, john.pratt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description john.pratt 2013-02-02 15:10:07 UTC
Created attachment 74092 [details]
Excel document causing the problem

Problem description: when copying cells from some microsoft excel files using excel all styles are copied across, even though they appear to be unused in the selected cells

Steps to reproduce:
1. copy cells in Microsoft Excel from attached document (e.g. cell A1)
2. paste into a new libreoffice document

Current behavior: cell is pasted, but a large number of styles are also copied from excel

Expected behavior: the cell is pasted and only relevant styles (probably none in this case) are copied across

Workaround: open excel file in libreoffice then copy across

Workaround2: copy from excel to a new libreoffice document, then copy from there to the real document

Additional problem: if you make the mistake of doing this you can unpaste using CTRL+Z, but you cannot remove the styles without deleting each one individually.

Tested using 3.5.7.2 and Version 4.1.0.0.alpha0+ (Build ID: 28b7359e00fec9fd3bfab3c9105cf250c4320a2)
TinderBox: Win-x86@6, Branch:master, Time: 2013-02-02_00:14:06
Operating System: Windows XP
Version: 3.5.7.2 release
Comment 1 Florian Reisinger 2013-04-21 15:13:57 UTC
I can confirm that with Version 4.0.3.1 (Build ID: a67943cd4d125208f4ea7fa29439551825cfb39) @Win7 x64
Comment 2 QA Administrators 2015-03-04 02:24:02 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1.2 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-03-03
Comment 3 Jean-Baptiste Faure 2015-03-15 16:38:16 UTC
From the first workaround I understand that the problem is in the copy operation in MS-Excel. Then why incriminate LibreOffice ?

Closing as NotOurBug. Please, feel free to reopen if you disagree.

Best regards. JBF