Download it now!
Bug 60365 - Y error bars cannot be added to charts in LO 4.0.0.rc2
Summary: Y error bars cannot be added to charts in LO 4.0.0.rc2
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.0.2 rc
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-02-06 13:18 UTC by Carlos Sevcik
Modified: 2013-04-22 12:35 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
A 3 bar chart (values in column B) and values for symmetric error bars in C. It is not possible to add the error bars under LO 4.0.0.rc2 (18.18 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-02-06 13:18 UTC, Carlos Sevcik
Details
See comment including Spreadsheth_test_2.ods (123.02 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-02-15 14:25 UTC, Carlos Sevcik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Sevcik 2013-02-06 13:18:01 UTC
Created attachment 74288 [details]
A 3 bar chart (values in column B) and values for symmetric error bars in C. It is not possible to add the error bars under LO 4.0.0.rc2

When you create even a very simple bar chart under LO 4.0.0.r2 it is impossible to create y correct error bars (didn't try x bars) of any kind. The either appear with wrong values or do not appear at all. A simple calc sheeth to test this is include as annex.
Comment 1 Joel Madero 2013-02-07 17:19:31 UTC
I can't reproduce this one with current master branch of 4.1

I'm marking as WFM, if you still have the issue with the release version of 4, please reopen the bug and we'll take a look at it.

Version 4.1.0.0.alpha0+ (Build ID: 027bb41aa16793e88e9fc1b3550c8c893363647)

Bodhi Linux
Comment 2 Carlos Sevcik 2013-02-08 00:46:00 UTC
Thanks Joel, I ma hurring to download 4.1 and give it a try. I liked 4.0.2 very much but I need error bars in my chart sine statistics is central to my work.

Carlos
Comment 3 Joel Madero 2013-02-08 00:58:11 UTC
Current stable release is 4.0.0.3 release ;) 4.1 is only master build which you won't want to do. 

Let us know if it works on 4.0.0.3 release (ie. the current stable release available as of today :) )
Comment 4 Carlos Sevcik 2013-02-08 01:48:04 UTC
Yes the bug as reported does not exist in L= 4.0.3 but it suffers of bug 56730 wich I reported for LO 3.6.x and does not exist in LO 3.5.x 

https://bugs.freedesktop.org/show_bug.cgi?id=56730
Comment 5 Joel Madero 2013-02-08 02:12:00 UTC
Why did you reopen this bug if you said "as reported it does not exist in 4.0.0.3"?
Comment 6 Carlos Sevcik 2013-02-08 02:36:18 UTC
Sorry for upsetting you Joel for my ignorance of the bugzilla protocol. I will post it as as bug of 4.0.3 which duplicates de bug of 3.6.x which is still unsolved and now was inherited by 4.0.3 :-( .
Comment 7 Joel Madero 2013-02-08 02:42:04 UTC
no no no I'm not upset at all ;) I assumed I was missing something. Your dedication in reporting a bug is exactly what we need to make LibreOffice a better product.

So in this case what we do is close this one as WORKSFORME (since we don't know which patch fixed it), then we just post a comment in fdo#56730 saying that it's still present in 4.0 stable. We don't want to open an identical bug report as 56730 just because the bug exists in 4.0

Again, please don't think that I am discouraging your input! It is greatly appreciated
Comment 8 Carlos Sevcik 2013-02-15 02:15:11 UTC
THe bug is not fixed. It does not show with the simple spreadshheat I posted. But when I tried 4.0.03 v of LO with an actual calc spreadsheath (fairly complex) which I use profesionally the error bars still could not be added. My problem is that I cannot submit the spreadsheath since it has corporative private data.

I had to downgrade LO to 3.5 in order to have a workable version.
Comment 9 Carlos Sevcik 2013-02-15 03:14:54 UTC
I just noticed that if I open the spreadsheath created with LO 3.5 with error bars, but open it with 4.0.0.3 the error bars are in the charts BUT INVIBLE, you will get only the option to edit them or erase them but you won't see them. Evereythink will look OK if you reopen the the same file with LO 3.5 once again.

Hope it helps.
Comment 10 Carlos Sevcik 2013-02-15 03:17:31 UTC
Sory for the typos.
Comment 11 Carlos Sevcik 2013-02-15 14:25:39 UTC
Created attachment 74871 [details]
See comment including Spreadsheth_test_2.ods

In Spreadsheth_test_2.ods error bars are included, they show under LO v 3.5xxx but not under LO 4.0.0.3.
Comment 12 Carlos Sevcik 2013-02-15 14:28:44 UTC
I managed to deface a page of my work spreadsheath as to remove confidential information. It is annexed as Spreadsheth_test_2.ods. The chart at bottom has data bars with error bars, the error bars shoe under LO Calc v 3.5xxxxx but not under LO Calc 4.0.0.3
Comment 13 Carlos Sevcik 2013-02-15 14:30:16 UTC
"shoe" means "show" in the comment above
Comment 14 Carlos Sevcik 2013-02-16 01:32:02 UTC
I tried Calc in LO 4.0.0.3 under MS Windows 7 (Installed in VirtualBox over Ubuntu 12.10) and the bug exists under Windows 7.
Comment 15 Joel Madero 2013-02-19 05:19:36 UTC
indeed, I see the issue now! Thanks for clarifying. 

Major is appropriate as there is apparent loss of data at least for those using version 4, furthermore regression.

Markus - want to take this one?
Comment 16 Carlos Sevcik 2013-02-19 07:19:51 UTC
To me is major. I won't be able to upgrade from 3.5 until this issue is fixed, and I like very much the rest I see in LO 4. Thanks.
Comment 17 Carlos Sevcik 2013-02-24 00:50:20 UTC
4.0.1.1 (Build ID: 2c0c17a6e4bee0ee28131ea4bdc47edc700d659) still has the bug
Comment 18 Markus Mohrhard 2013-03-25 14:28:18 UTC
Please test in master/4.0.2
Comment 19 Michael Meeks 2013-03-28 10:22:46 UTC
Loading the sheet in comment #12: https://bugs.freedesktop.org/attachment.cgi?id=74871 in master and 4.0.2rc1 shows no error bars :-)

Well - actually it seems to show Y error bars present (but not rendered) in a primarily x bar direction - so perhaps there is some minor X/Y confusion ?
Comment 20 Markus Mohrhard 2013-03-28 10:41:43 UTC
So the big confusion here comes from having 2 independent issues in one bug report. Please use one bug report per issue.

The adding error bars bug has been fixed while there seems to be another issue with opening the file.
Comment 21 Markus Mohrhard 2013-03-28 11:51:08 UTC
And looking into the test file the range is missing so the problem is expected.

If you can still produce these documents with 4.0.2.2/master please give me a step by step instruction.

But this has to be with a new and clean document and not with an already broken document.
Comment 22 Markus Mohrhard 2013-04-22 12:00:52 UTC
I suppose we can close this bug now.
Comment 23 Carlos Sevcik 2013-04-22 12:21:28 UTC
I have checked extensively LO v4.02 under Linux (and less extensively under Windows 7) and the bug seem completely fixed. So this bugzilla thread may certainly be closed. Many thanks.