Download it now!
Bug 60443 - When the clipboard contents are pasted in Writer, only text is pasted, not images
Summary: When the clipboard contents are pasted in Writer, only text is pasted, not im...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-07 19:58 UTC by anil kumar
Modified: 2018-07-16 15:33 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
LibreOffice 4.0.3.1rc are affected too... (106.13 KB, image/png)
2013-05-07 20:52 UTC, Maximiliano Castañón
Details

Note You need to log in before you can comment on or make changes to this bug.
Description anil kumar 2013-02-07 19:58:35 UTC
i am using 4.0.0 rc3 when i copied a data from a web site (say www.yahoo.com) and i pasted that data in the liber office writer, data is pasted in to document but images are failed to pasted 

steps
1.open liber office write
2.open any web site (which contain written data and images)say www.yahoo.com
3.copy entire page
4.paste it in liber office writer
 
expected
both data and images has to be pasted sucessfully

result
images are failed to pasted in the writer
Comment 1 Joel Madero 2013-02-21 20:46:01 UTC
Version 4.1.0.0.alpha0+ (Build ID: 9601a571d42b0199bdccf2256fc8be82e14af8a
Date:   Mon Feb 18 23:22:17 2013 +0100
Bodhi Linux 2.2

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
I suspect there are duplicates of this but I haven't tracked them down. For now marking as:

New (confirmed)
Major (loss of data on copy/paste -- no images)
High (quite a frequent thing for users to do)



Also just verified on LibreOffice 3.5.0 so I'm changing version.

@anil - version is oldest version we see the issue, not the latest tested on. If you find another bug that looks like this one please add it in comments. Thanks!
Comment 2 Maximiliano Castañón 2013-05-07 20:52:53 UTC
Created attachment 79007 [details]
LibreOffice 4.0.3.1rc are affected too...

This affects LibreOffice 4.0.3.1rc too

The links of the images appears but not like expected... 

http://subir.inodochile.net/images/1367959638.png
Comment 3 Maximiliano Castañón 2013-05-07 20:56:48 UTC
(In reply to comment #2)
> Created attachment 79007 [details]
> LibreOffice 4.0.3.1rc are affected too...
> 
> This affects LibreOffice 4.0.3.1rc too
> 
> The links of the images appears but not like expected... 
> 
> http://subir.inodochile.net/images/1367959638.png

That happens when you copy text and an images exists in the copied text, so that red characters appears... that are the URL to the link of the images... that even takes lot of seconds after it show the red chars and then disappear.
Comment 4 Joel Madero 2013-05-07 20:57:45 UTC
in the future please reply directly to FDO vs. through email as it clogs the comments up with extra text :)

Thanks!
Comment 5 narayanaras 2014-04-10 06:02:05 UTC
The problem still exists in v4.2.3.2 also.

BTW when the content (text+images) is pasted, the text is pasted instantly (no delays at all). But there is absolutely no trace of the images- Not even placeholders.
Comment 6 QA Administrators 2015-06-08 14:42:58 UTC Comment hidden (obsolete)
Comment 7 Buovjaga 2015-08-02 11:29:21 UTC
I don't reproduce this. Website contents can be anything, though. I don't know, if we can generalize this problem to a bug report.
For example, copying the English Wikipedia main page to Writer crashes it for me: https://en.wikipedia.org/wiki/Main_Page

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 902255645328efde34ddf62227c8278e8dd61ff0
TinderBox: Win-x86@39, Branch:master, Time: 2015-07-30_03:52:07
Locale: en-US (fi_FI)
Comment 8 QA Administrators 2016-09-20 10:21:47 UTC Comment hidden (obsolete)
Comment 9 Telesto 2018-07-16 13:05:55 UTC
No repro
Version: 6.0.0.1.0+
Build ID: 47cc374c0659fd3db74a1b184c870eaa56bc385b
CPU threads: 4; OS: Windows 6.3; UI render: GL; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 10 Buovjaga 2018-07-16 15:33:24 UTC
Yep, it's high time we close this.