Bug 60456 - : Bug Submission Assistant offers wrong choice for LibreOffice 4.0.0.3
Summary: : Bug Submission Assistant offers wrong choice for LibreOffice 4.0.0.3
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other All
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 60567 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-02-07 23:27 UTC by Roger Sperberg
Modified: 2013-02-11 17:52 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The faulty dropdown listing a nonexistent version of LibreOffice (22.90 KB, image/jpeg)
2013-02-07 23:27 UTC, Roger Sperberg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roger Sperberg 2013-02-07 23:27:32 UTC
Created attachment 74390 [details]
The faulty dropdown listing a nonexistent version of LibreOffice

Problem description: 
I was unable to report a bug in installation of Version 4.0.0.3 of LibreOffice using the Bug Submission Assistant.

Steps to reproduce:
1. Went to webpage www.libreoffice.org/get-help/bug
2. Chose Installation as the component, (all other problems) as the sub-compoent and 4.0.0.3 rc as the Version
3. Supplied details and screen capture and clicked submit
4. The page did not submit and the message supplied was something like "There is no such version as 4.0.0.3 rc of LibreOffice."

Current behavior:
Chose the closest option in the dropdown menu for version, but it was not an acceptable response.

Expected behavior:
The Version dropdown menu would list 4.0.0.3 release as the option.
              
Operating System: All
Version: unspecified
Comment 1 Roger Sperberg 2013-02-07 23:33:37 UTC
I downloaded the 4.0.0 installer today from LibreOffice and was unable to install it, so I came to the Bug Submission Assistant to report the details.

The dialog box of the installer clearly said it was version 4.0.0.3, and so when I chose the Version number on that webpage I selected "4.0.0.3 rc" as the option.

However, the report was not submitted because, the page reported, there is no such thing as Version 4.0.0.3 rc of LibreOffice.

I finally was able to submit my report by changing the version to unspecified.

So for this bug report, I initially entered version unspecified as well. I have changed that here to be 4.0.0.3 release.

You may want to make it clearer how to report a bug in the Bug Submission Assistant as opposed to the LibreOffice software itself.
Comment 2 Robinson Tryon (qubit) 2013-02-09 00:46:35 UTC
Several users are using the standard URL for the BSA (https://www.libreoffice.org/get-help/bug) and running into this problem, e.g.

http://ask.libreoffice.org/en/question/11702/corrupt-characters-in-libreoffice-4-with-nouveau/

Per email to the website list, this problem only exists for this url:
http://listarchives.libreoffice.org/global/website/msg10013.html

As a WORKAROUND, one may use the following url, which does not exhibit the incorrect behavior:

https://bugassistant.libreoffice.org/libreoffice/bug/bug.html

Increasing Importance to High, Major, as we just released LO 4.0 and have been directing users to this URL consistently.
Comment 3 Robinson Tryon (qubit) 2013-02-09 00:48:00 UTC
As a possible quickfix, could we please redirect (using mod_redirct, PHP, or whatever) the buggy url to the url that is working properly?
Comment 4 Robinson Tryon (qubit) 2013-02-09 00:49:42 UTC
Just confirmed on Ubuntu 12.04.2, FF 18.0.2

UNCONFIRMED -> NEW
Comment 5 Joel Madero 2013-02-10 06:16:24 UTC
*** Bug 60567 has been marked as a duplicate of this bug. ***
Comment 6 Joel Madero 2013-02-11 17:52:31 UTC
Bug fixed. Thanks Rob!