Bug Hunting Session
Bug 60467 - EDITING: A black Text copied from a Draw Diagram embedded in Writer directly to Writer is invisible because it uses white font colour
Summary: EDITING: A black Text copied from a Draw Diagram embedded in Writer directly ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-08 04:23 UTC by Petar Velkovski
Modified: 2015-02-25 18:43 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Writer document containing my drawing (15.89 KB, application/vnd.oasis.opendocument.text)
2013-02-20 06:41 UTC, Petar Velkovski
Details
screencopy in LO 4.4.2.0.0+ (97.92 KB, image/png)
2015-02-25 05:36 UTC, Jean-Baptiste Faure
Details
test file with copy&paste from the graphics (14.85 KB, application/vnd.oasis.opendocument.text)
2015-02-25 18:43 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petar Velkovski 2013-02-08 04:23:58 UTC
I have created a diagram using Draw. The diagram consists of a number of shapes that have some text entered into them (you embed the text by double clicking on the shape). Then i select the diagram and copy it. Then I paste it into a Write document that already has some text in it. If I select a text from the Write document and try to paste it into some of the diagram shapes it works fine(for instance to fix a spelling error of a term used in the diagram). When I select a text embedded in the diagram (embedded in some shape of the diagram) and copy it and then try to paste it in the Writer document, It's not working. The text cursor is moving a few characters, but the text is not there. Well it actually works, but the pasted text is probably white. When I select the "nothingness" and change the font color, the text appears.
Comment 1 Petar Velkovski 2013-02-08 04:43:27 UTC
Actually I just realized that the text in my Draw diagram uses Automatic color but it's shown as black, but that doesn't mean that it should be pasted as white in Writer!
Comment 2 Joel Madero 2013-02-20 04:34:31 UTC
Please attach said diagram.

Marking as NEEDINFO, once you attach open this up as UNCONFIRMED and I'll confirm what you're saying.
Comment 3 Petar Velkovski 2013-02-20 06:41:43 UTC
Created attachment 75159 [details]
Writer document containing my drawing

Open the document, double click on a shape containing text, selcet the text and copy it. Try to paste the text below the drawing in the same document. On my computer the pasted text is invisible (white) until I selct it and change the font colour.
Comment 4 Joel Madero 2013-02-21 20:55:35 UTC
Another strange one!

Version 4.1.0.0.alpha0+ (Build ID: 9601a571d42b0199bdccf2256fc8be82e14af8a)
Date:   Mon Feb 18 23:22:17 2013 +0100
Bodhi Linux 2.2


+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Marking as:
New (confirmed)
Normal (would be major but workaround is just to change font color)
High (data not being transferred correctly on copy/paste)

Thanks again
Comment 5 A (Andy) 2015-02-12 20:14:56 UTC
For me not reproducible with LO 4.4.0.3, Win 8.1.

Can anybody confirm that this bug still persists?
Comment 6 Jean-Baptiste Faure 2015-02-25 05:36:56 UTC
Created attachment 113661 [details]
screencopy in LO 4.4.2.0.0+

Attached is what I see when I open the document in LibreOffice 4.4.2.0.0+ built at home under Ubuntu 14.10. Is it what is expected?

Best regards. JBF
Comment 7 Petar Velkovski 2015-02-25 09:00:47 UTC
Jean-Baptiste Faure, in order to reproduce the bug, you have to double click on the drawing and select some text from the drawing, and than paste it as ordinary text anywhere in the document. Simply opening the document is not what would reproduce the bug.

Anyway, I tried to reproduce the bug with LibreOffice 4.4.1.2 under Ubuntu 14.04.2 and it seams that the bug has been fixed.
Comment 8 Joel Madero 2015-02-25 15:13:45 UTC
Per last comment - closing as WFM
Comment 9 Jean-Baptiste Faure 2015-02-25 18:43:38 UTC
Created attachment 113683 [details]
test file with copy&paste from the graphics

> [...] in order to reproduce the bug, you have to double click on the drawing and 
> select some text from the drawing, and than paste it as ordinary text anywhere
> in the document. Simply opening the document is not what would reproduce the bug.

Indeed copy&paste works as expected.

Best regards. JBF