Download it now!
Bug 60506 - Comment information lost when saving to .doc or .docx formats
Summary: Comment information lost when saving to .doc or .docx formats
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-08 17:30 UTC by cejpersonal
Modified: 2016-04-18 16:29 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
The ODT file with comments (10.40 KB, application/vnd.oasis.opendocument.text)
2013-02-08 17:30 UTC, cejpersonal
Details
A resulting flawed .DOC file (10.00 KB, application/msword)
2013-02-08 17:34 UTC, cejpersonal
Details
A resulting flawed .DOCX file (4.54 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-02-08 17:35 UTC, cejpersonal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cejpersonal 2013-02-08 17:30:05 UTC
Created attachment 74439 [details]
The ODT file with comments

When a document is saved in .DOCX format, the comment, author, and range are saved. An empty comment appears when the document is opened with Word 2007.

When a document is saved in .DOC format, the comment and its text are saved, but the comment range is lost. The area highlighted by the comment contains zero characters. (Which is the way Writer behaved before comment ranges were added.)

While not severe for most users, these bugs prevent LO's use by writers and editors exchanging manuscripts during the edit process, because the information lost is too important to give up.

I have attached a sample document for export testing.
Comment 1 cejpersonal 2013-02-08 17:33:09 UTC
Oops. I mistyped something. When saved to .DOCX format, the comment, author, and range are saved, but the actual comment TEXT is not. All you get is an empty comment showing who created it.
Comment 2 cejpersonal 2013-02-08 17:34:07 UTC
Created attachment 74440 [details]
A resulting flawed .DOC file
Comment 3 cejpersonal 2013-02-08 17:35:24 UTC
Created attachment 74441 [details]
A resulting flawed .DOCX file
Comment 4 Joel Madero 2013-02-21 21:06:53 UTC
Version 4.1.0.0.alpha0+ (Build ID: 9601a571d42b0199bdccf2256fc8be82e14af8a
Date:   Mon Feb 18 23:22:17 2013 +0100
Bodhi Linux 2.2

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Verified:
New (confirmed)
Major (loss of data in comments for popular format)
High (default is Highest but this so far only has one user reporting that I can see so marking as High)

@cejpersonal - is this a regression? Unfortunately I don't have access to 3.6 right now so I can't test. If it is I'll do further testing/investigation for the developers. Thanks!
Comment 5 cejpersonal 2013-02-26 14:55:05 UTC
@Joel - Half and half. The loss of comment TEXT in .DOCX format is indeed a regression. The loss of comment RANGE in .DOC format is new, because in the past Writer didn't even have comment ranges.
Comment 6 Alex Thurgood 2013-03-18 08:50:56 UTC
Also reported on user mailing list by Rogier F. van Vlissingen.


Alex
Comment 7 K.M. 2013-03-19 10:05:51 UTC
(In reply to comment #5)
> @Joel - Half and half. The loss of comment TEXT in .DOCX format is indeed a
> regression. 

Do you refer to bug 33463 ?

>The loss of comment RANGE in .DOC format is new, because in the
> past Writer didn't even have comment ranges.
Comment 8 Rogier van Vlissingen 2013-03-19 11:45:48 UTC
An additional issue that appears to be related is that the numbering and formatting of footnotes and endnotes is also impacted by the conversions, or even by the mere saving of the file, which again makes the use of LO for editing projects nearly impossible.
Comment 9 Rogier van Vlissingen 2013-03-19 11:48:38 UTC
Note that this includes the fact that sometimes going from .odt to .doc or .docx footnotes/or end notes may change from arabic numbering 1,2,3,4 etc. to roman numbering i,ii,ii, iv etc. and typically one or two tabs are inserted between the foot/end note number and the text at the time of saving.
Comment 10 tommy27 2016-04-16 07:23:54 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.5 or 5.1.2 https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

- Update the version field
- Reply via email (please reply directly on the bug tracker)
- Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-04-16
Comment 11 K.M. 2016-04-18 09:17:03 UTC
Works for me on LO 5.1.2.2 on Linux (64bit/RPM install)
Comment 12 sdc.blanco 2016-04-18 16:29:07 UTC
Works for me:  LO 5.1.2.2 Windows 7