Bug Hunting Session
Bug 60520 - I can't select cell content with keyboard in read-only document
Summary: I can't select cell content with keyboard in read-only document
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-08 22:23 UTC by Fco. Javier M. C.
Modified: 2015-02-21 23:30 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fco. Javier M. C. 2013-02-08 22:23:41 UTC
I need to copy-paste cell content from read-only spreadsheet document but, it's not possible to select cell content using keyboard keys (shift + left/right arrow). It's possible with mouse. When I click inside the cell the cursos starts to blink but it's unusable.
Comment 1 m.a.riosv 2013-02-10 00:10:38 UTC
Hi Francisco Javier, thanks for reporting.

Please can you verify if the option in:
Menu/Tools/Options/LibreOffice Writer/Formatting Aids/Cursor in protected areas solve your issue.
Comment 2 Fco. Javier M. C. 2013-02-10 10:54:42 UTC
Hello mariosv

First, this option is not available in Calc (spreadsheet), but I try through Writer, but without luck.

Thank you!
Comment 3 m.a.riosv 2013-02-10 14:14:53 UTC
Hi Francisco,
writer works for me and the cursor is visible activating in:
Menu/Tools/Options/LibreOffice/Accesibility - Use text selection cursor in read-only text documents.

I can confirm in calc it is not possible.
Version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89)

Changed the status to new.

Please Francisco, change the importance from normal to enhancement, I think shows better the situation because this option was never available in calc.
Comment 4 QA Administrators 2015-02-19 15:35:20 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.0.3 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-02-19
Comment 5 Fco. Javier M. C. 2015-02-21 23:30:32 UTC
Now it's working. Thank you!

Tested with Libreoffice 4.4.0.3 / GNU/Linux OpenSUSE 13.2 64 bit.