Download it now!
Bug 60548 - FILEOPEN: V4.0.0.3 - Can't open ods files across network on windows machine
Summary: FILEOPEN: V4.0.0.3 - Can't open ods files across network on windows machine
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: x86 (IA32) Linux (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-02-09 15:58 UTC by John Ervin
Modified: 2013-05-05 21:26 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Ervin 2013-02-09 15:58:37 UTC
Problem description: 

Steps to reproduce:
1. I go to File/Open and go to a network mounted file system
2. I go to a network mounted file system and try to open an ODS file
3. I get error message "General Error. General Input/Output error"

Current behavior:
I'm trying to open a file that opened fine with 3.6.5.2.  Actually any .ods file fails when you try to open it.  This occurs when the file is actually located on a windows XP SP3 system and is mounted via my home network to my Ubuntu 12.10 system.  .xls files open fine, it's just .ods files that fail.  .ods files on my actual Ubuntu machine open correctly.  I didn't check the text editor files etc. Both systems are at current maintenance levels.

Expected behavior:
I expect .ods files to open correctly like the .xls files do across my network.  

This is a duplicate report.  
              
Operating System: Ubuntu
Version: 4.0.0.2 rc
Last worked in: 3.6.5.2 release
Comment 1 Markus Mohrhard 2013-02-10 18:53:20 UTC
Please check a daily build for 4.0.1 because it looks like the samba problem Michael fixed recently.
Comment 2 John Ervin 2013-02-10 20:40:11 UTC
Just installed the daily version 4.0.1.0 and that seemed to resolve the issue.
Comment 3 John Ervin 2013-02-10 20:43:50 UTC
libreoffice-4-0~2013-02-10_05.25.56_LibO-Dev_4.0.1.0_Linux_x86_deb.tar.gz to be mostly exact.
Comment 4 John Ervin 2013-02-15 13:03:40 UTC
Any idea when the fix will make it into the main stream rather than running this development version?
Comment 5 John Ervin 2013-05-05 21:26:45 UTC
The problem no longer seems to exist on my system at Version 4.0.3.2 (Build ID: 400m0(Build:2)).  I'd say this one seems resolved.