Bug 60594 - VIEWING UI: Page count in status bar does not reflect setting "Print automatically inserted blank pages"
Summary: VIEWING UI: Page count in status bar does not reflect setting "Print automati...
Status: RESOLVED DUPLICATE of bug 52316
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:4.1.0
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-10 13:26 UTC by webofht-libreofficebugs002
Modified: 2018-02-06 10:19 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot showing incorrect page count (187.37 KB, application/vnd.oasis.opendocument.graphics)
2013-02-10 13:26 UTC, webofht-libreofficebugs002
Details
Document showing the incorrect page count (8.76 KB, application/vnd.oasis.opendocument.text)
2013-02-10 13:27 UTC, webofht-libreofficebugs002
Details

Note You need to log in before you can comment on or make changes to this bug.
Description webofht-libreofficebugs002 2013-02-10 13:26:07 UTC
Created attachment 74542 [details]
Screenshot showing incorrect page count

Problem description: The page count does not match the visible pages in LibreOffice version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89). The operating system used is Linux debian 2.6.32-5-686 #1 SMP Sun Sep 23 09:49:36 UTC 2012 i686 GNU/Linux. 

$ cat /opt/libreoffice4.0/program/versionrc
[Version]
AllLanguages=en-US
BuildVersion=
buildid=7545bee9c2a0782548772a21bc84a9dcc583b89
ExtensionUpdateURL=http://updateexte.libreoffice.org/ExtensionUpdateService/check.Update
ProductBuildid=103
ProductMajor=400
ProductMinor=0
ProductSource=OOO400
ReferenceOOoMajorMinor=3.4
UpdateID=LibreOffice_4_en-US
UpdateURL=http://update.libreoffice.org/check.php?pkgfmt=deb
UpdateUserAgent=<PRODUCT> (${buildid}; ${_OS}; ${_ARCH}; BundledLanguages=${AllLanguages})
Vendor=The Document Foundation

Steps to reproduce:
1.  File → New → Text Document 
2. → Insert → Footer → Default Style → Footer 
3. → Type Page 
4. → Insert → Fields → Page Number 
5. → Main body of document
6. → Hit Enter repeatedly to create another page  
7. → Format → Styles and Formatting → Page Styles → All 
8. → Right-click Default Style → Modify... 
9. → Footer 
10. → Uncheck Same content on first page → OK 
11. → Page 2 → Click first paragraph
12. → Format → Paragraph 
13. → Text Flow → Insert 
14. → With Page Style 
15. → Page number → 1 → OK

Only two pages are displayed, but the page count indicates three pages. 

(I do not know if the printer will print three pages instead.)

See the attached document and screenshot.

Current behavior: The page count does not match the actual number of visible pages.

Expected behavior: The page count should match the actual number of visible pages.


Regards,
C. H. D.
Comment 1 webofht-libreofficebugs002 2013-02-10 13:27:39 UTC
Created attachment 74544 [details]
Document showing the incorrect page count
Comment 2 Thomas van der Meulen 2013-02-10 15:21:53 UTC
Thank you for reporting this bug,
I can reproduce this bug running 4.0.0.3 on Windows 7 


ps:Wen i print it out its just 2 pages.
Comment 3 Jorendc 2013-02-10 17:05:35 UTC
I can reproduce this using Linux Mint 14 x64 and LibreOffice 4.0.0.3 rc3 (=release)

@Miklos: following the release notes this feature 'same content on first page' is created/developed by you. Do you have any time to look at this (or add some code pointers?).

Kind regards,
Joren
Comment 4 webofht-libreofficebugs002 2013-02-11 12:43:10 UTC
I would like to change this issue to an enhancement request because the page count should display consistent numbers before and after counting the automatically inserted pages (A.I.P.).

At present, the sample document shows:

Page 1 / 3     on the first page
Page 1    3 / 3      on the second page

This is confusing, I am afraid.

The page count should be consistent, e.g.

(without counting (A.I.P.))  vs (counting (A.I.P.))

Page 1 / 2     1 / 3 on the first page
Page 2 / 2     3 / 3 on the second page

The user should be able to view the correct page count in a consistent way.
Comment 5 Commit Notification 2013-04-10 16:51:21 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=43b2d676b5e2d3eb3788ff480b2ab2201a51b2f9

fdo#60594: Fix crash in the document (does not fix the original report).



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Cor Nouws 2013-04-10 18:37:58 UTC
Hi guys,

Could you please test how this works with older versions, e.g. OpenOffice.org 1.0.2 :-)

Unless I really understand/read this wrong: it is long standing behaviour in OpenOffice.org / LibreOffice.
A odd page is expected to start on the left side of a book /  double sided printed document.
That is the reason for the described behaviour.

And this is related to automatically inserting empty pages: Tools > Options > Writer > Printing > Automatically insert empty pages when printing (or somtheing like that - reading the Dutch version now).

So IMHO: NOTABUG ...
Comment 7 Cor Nouws 2013-04-10 18:39:30 UTC
(In reply to comment #6)

> A odd page is expected to start on the left side of a book /  double sided
> printed document.

Of course the *right* side (always difficult for me to choose the right one ;-) )
Comment 8 webofht-libreofficebugs002 2013-04-11 01:40:56 UTC
(In reply to comment #6)
> And this is related to automatically inserting empty pages: Tools > Options
> > Writer > Printing > Automatically insert empty pages when printing (or
> somtheing like that - reading the Dutch version now).
> 
> So IMHO: NOTABUG ...

I am not an expert. I think it's an enhancement request in the UI.

To make things clear, there could be a way to show the page numbers in one way and to show them in the other way, e.g.:

(without counting (A.I.P.))  vs (counting (A.I.P.))

Perhaps, there should be a switch like double-clicking or right-clicking to reveal the desired format of page numbers. Thanks.
Comment 9 Dieter Praas 2017-06-23 08:01:36 UTC
I don't think it is a bug or it has been solved during the last years. It depends on how you do the page break:

1. Open attachment from comment 1
2. Move cursor to the page break => edit page break
3. Text Flow => disable "page number"
4. Press OK => Page count shows 2/2


For me it is logical, because if you start with page number 1 after a page break you have always have a new sheet and the blank backside of the first sheet (page 2) isn't displayed.

So my proposal is to close this bug as WORKSFORME or NOTABUG. Do you agree? => changed to NEEDINFO
Comment 10 QA Administrators 2018-01-02 10:14:25 UTC Comment hidden (obsolete)
Comment 11 Cor Nouws 2018-01-02 11:20:17 UTC
(In reply to webofht-libreofficebugs002 from comment #8)

> (without counting (A.I.P.))  vs (counting (A.I.P.))

So currently the status bar info on the second page in view is
"Page 3 of 3 (Page 1)"
This independent of the setting "Print automatically inserted blank pages"
(The "(Page 1)" is irrelevant for this issue - it is displayed to show the page number as set by the user.)

The request is
option active:
  "Page 3 of 3 (Page 1)"
option disabled
  "Page 2 of 2 (Page 1)"

That sounds good.

I do not see any problems with Export to PDF?
Then, on the first tab, one can set "Export automatically inserted blank pages"
Choosing that on export, will not change the numbering of pages (as set by the user with fields in e.g. the footer.)

So set to new.
Comment 12 Gabor Kelemen 2018-02-06 10:19:22 UTC
I think this is the same as bug #52316 - this is a different way of triggering it.

*** This bug has been marked as a duplicate of bug 52316 ***