Bug Hunting Session
Bug 60604 - Impress Remote: Non-English characters in speaker notes garbled
Summary: Impress Remote: Non-English characters in speaker notes garbled
Status: RESOLVED FIXED
Alias: None
Product: Impress Remote
Classification: Unclassified
Component: Android Remote App (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.1.0 target:4.0.3
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-10 18:44 UTC by Alon Amster
Modified: 2015-02-13 19:39 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Android Screenshot (31.38 KB, image/jpg)
2013-02-10 18:44 UTC, Alon Amster
Details
Presentation example (14.06 KB, application/vnd.oasis.opendocument.presentation)
2013-03-14 11:51 UTC, Michal Sylwester
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alon Amster 2013-02-10 18:44:33 UTC
Created attachment 74560 [details]
Android Screenshot

Problem description: 
I have successfully RC'd a presentation from my Android device, with LibreOffice 4.0.1 on Ubuntu 12.10.
However, If I add Hebrew speaker notes, they appear in gibberish.

Steps to reproduce:
1. Install the RC Android application.
2. Pair with the PC and configure Impress.
3. Create a slide with a note that contains non-unicode (e.g, Hebrew) characters.
4. Play the presentation from the Android application and navigate to the created slide.

Current behavior:
Notes are wrongly decoded.
Expected behavior:
Original note text should appear (e.g, the original Hebrew text).

The attachment shows a slide with Hebrew content (displayed properly) and a mixed language note, which Hebrew section is wrongly interpreted by the application.
Comment 1 Thorsten Behrens (CIB) 2013-02-18 09:39:40 UTC
Two more examples:

http://imagebin.ubuntu-gr.org/1361047311.jpg

and

http://imagebin.ubuntu-gr.org/1361047198.png

-> confirmed.
Comment 2 Simos Xenitellis 2013-02-18 18:07:28 UTC
The problem is that the text box in the Android app is forcing text to appear in the ISO-8859-1 encoding, instead of defaulting to UTF-8.
Comment 3 Michael Meeks 2013-03-11 10:32:26 UTC
I'd appreciate testing of a master build as/when one is done - it should appear here at some stage:

http://dev-builds.libreoffice.org/daily/master/Android-ARM@24-Bytemark-Hosting/

if it works - please poke the bug for a back-port to 4-0 and hence the store.

Thanks for reporting !
Comment 4 Commit Notification 2013-03-11 10:32:35 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b5e6c7d278abd618ce79a7e0a37bda176bd65619

fdo#60604 - tag notes text as UTF-8.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Michal Sylwester 2013-03-13 08:44:29 UTC
Problem still there on 2013-03-13_06.12.13 build.
Comment 6 Michael Meeks 2013-03-14 10:49:42 UTC
Oh - that's annoying :-) we build the notes HTML as UTF-8 for sure:

OString ImagePreparer::prepareNotes( sal_uInt32 aSlideNumber )
{
...
    return OUStringToOString(
        aRet.makeStringAndClear(), RTL_TEXTENCODING_UTF8 );
}

in the UI code - so; broadly I'm stumped. Given that we're doing this right ;-) is it possible that Android has no good font coverage for your characters ? [ I suppose not but ... ;-] so I don't understand.
Comment 7 Thorsten Behrens (CIB) 2013-03-14 11:19:40 UTC
(In reply to comment #5)
> Problem still there on 2013-03-13_06.12.13 build.
>
Can you attach minimal odp file that shows the problem for you with the latest version (http://dev-builds.libreoffice.org/pre-releases/sdremote/playstore/ImpressRemote.apk)?
Comment 8 Michal Sylwester 2013-03-14 11:51:30 UTC
Created attachment 76523 [details]
Presentation example

Slide and notes should show same characters. Top line is some Japanese, bottom some specific Polish characters. Neither show up correctly for me.
Comment 9 Commit Notification 2013-03-14 12:08:16 UTC
Artur Dryomov committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=04ab54f0c74ef0edcdd3ede3a5046a02f4bc90b1

fdo#60604 - fix Impress remote client speaker notes encoding



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Michael Meeks 2013-03-14 13:42:04 UTC
Thanks Artur - just reviewed and pushed to -4-0 - will be in the 4.0.2 impress remote update in a couple of weeks I think :-)
Comment 11 Commit Notification 2013-03-14 13:45:17 UTC
Artur Dryomov committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=61686edf7074ab72d03ca2f73022797443a61fa9&h=libreoffice-4-0

fdo#60604 - fix Impress remote client speaker notes encoding


It will be available in LibreOffice 4.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Robinson Tryon (qubit) 2015-02-13 19:39:00 UTC
Moving bug to (new) 'Impress Remote' product.