Bug 60666 - VIEWING: Calc doesn't show cell color background when dark theme is use in the desktop
Summary: VIEWING: Calc doesn't show cell color background when dark theme is use in th...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.2 rc
Hardware: Other Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-11 14:10 UTC by Marcelo Ruiz
Modified: 2016-05-20 05:36 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
cells of different colors (6.93 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-02-11 18:23 UTC, Brenda Granados
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcelo Ruiz 2013-02-11 14:10:02 UTC
Problem description: 

Steps to reproduce:
1. Install Boje Theme in Ubuntu/Mint: 
sudo add-apt-repository ppa:upubuntu-com/gtk3 
sudo apt-get update 
sudo apt-get install boje-theme
2. Open Calc and change the background color of a cell to yellow (or another color).
3. Save the document.
4. Close Calc.
5. Set the desktop theme to boje-turquoise (for example).
6. Open Calc.
7. Open the saved document.
8. Verify the cell background color.

Current behavior:
The cell color is actually set to the correct color, but it is not shown when a dark theme is used. 

Expected behavior:
The cell background should be shown.

By the way: I have installed LibreOffice 4.0.3 and it is not listed in the website dropbox. So I need to select another version so I can submit the bug report.

              
Operating System: Ubuntu
Version: 4.0.0.2 rc
Comment 1 Brenda Granados 2013-02-11 18:23:03 UTC
Created attachment 74635 [details]
cells of different colors

Attached sample .ods file with some cells changed to yellow and pink.
Comment 2 Brenda Granados 2013-02-11 18:25:32 UTC
I confirmed this on Ubuntu 12.04 using Libre Office 4.0.

The cell colors are not visible using the Boje theme, but any default Ubuntu theme is okay. I also tried changing a cell color while using the Boje theme, and it still did not show. If you right click on a cell that you know has a different background, and choose Format Cell, it still shows the different color (pink or yellow in the attachment) is selected.
Comment 3 Brenda Granados 2013-02-11 18:57:22 UTC
I updated the status of this to NEW. I set the priority to Minor, because there is no loss of data, and this problem exists with a select theme on Ubuntu.
Comment 4 Marcelo Ruiz 2013-02-11 22:41:30 UTC
An additional note: This is a problem I reported in the first version of LibreOffice. It does happen with several dark themes, Boje is just an example (Delorean-dark, FlatStudio Dark, Mediterranean Dark, Moonrise, OMG-Dark, and so on), so it is not limited to Boje.
Comment 5 chalucha 2013-05-25 14:10:33 UTC
I found a solution here: http://en.libreofficeforum.org/node/4612

Unchecking a bow in:
Tools > Options > LibreOffice > Accessibility > Automatically detect high-contrast mode of the operating system

It works for me (Libre Office 4.0.3.3)
Comment 6 QA Administrators 2015-03-04 02:24:32 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1.2 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-03-03
Comment 7 Buovjaga 2015-03-24 17:34:13 UTC
This feature of adapting to dark themes has been removed. Setting to WFM.
If for somehow you are still seeing this, feel free to set back to NEW.
Comment 8 Adolfo Jayme 2016-05-19 21:06:49 UTC
(In reply to Buovjaga from comment #7)
> This feature of adapting to dark themes has been removed.

???
Comment 9 Buovjaga 2016-05-20 05:36:29 UTC
(In reply to Adolfo Jayme from comment #8)
> (In reply to Buovjaga from comment #7)
> > This feature of adapting to dark themes has been removed.
> 
> ???

Yes, the automatic adaptation was removed. Right now I can't find the report where the decision was made.