Bug 60825 - Spurious values in Draw bitmap export dialog fields after export resolution change
Summary: Spurious values in Draw bitmap export dialog fields after export resolution c...
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
(earliest affected) release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
Depends on:
Reported: 2013-02-14 07:12 UTC by Steven Kirk
Modified: 2015-06-18 15:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:

Draw document used to replicate the export bug (60.10 KB, application/vnd.oasis.opendocument.graphics)
2013-02-14 07:12 UTC, Steven Kirk

Note You need to log in before you can comment on or make changes to this bug.
Description Steven Kirk 2013-02-14 07:12:47 UTC
Created attachment 74794 [details]
Draw document used to replicate the export bug

Problem encountered with, Win 7 Home Premium.
Tried to export a whole page from Draw (see attached document, containing a single JPEG file inserted as a Picture). Selected PNG output format (aside: bug also appears when using BMP as output format). On first appearance, bitmap output dialog shows resolution as 96 pixels per inch. 
I edited the resolution field to 300 pixels per inch, and the other two fields updated as expected. I then tried to edit the width and height fields to width 210 mm and height 297 mm (in order to export the whole page). These two fields did not respond correctly to editing (using delete, backspace and keyboard, or by pasting values from clipboard), inserting spurious values (e.g. 999.99). Attempting to retype the values in these fields failed to resolve the problem.

Finally worked around the problem by: on entry, leaving the width and height fields alone, but pasting the text value '300' into the resolution field from clipboard (typed and copied from another text editor) to the resolution field with the listbox set to 'pixels/inch'.

It appears that if recalculation of the values in the width and height fields is done after adjusting the resolution, it is not possible to correctly edit the resulting width and height fields.
Comment 1 Steven Kirk 2013-02-14 07:18:40 UTC
Original process seems to work OK with on Win 8, except that manually editing the width and height values still occasionally inserts spurious digits, which fortunately can be edited out.
Comment 2 Steven Kirk 2013-02-14 07:21:19 UTC
Odd that pasting '300' into the resolution field worked, but typing it in didn't.
Comment 3 A (Andy) 2013-03-29 23:07:54 UTC
reproducible with LO (Win7 Home, 64bit)

@Fridrich: Could this issue maybe be something for you?
Comment 4 QA Administrators 2015-04-19 03:22:38 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)


2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword

Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-18
Comment 5 Buovjaga 2015-06-18 15:04:25 UTC
No repro, WFM. Feel free to set to NEW, if this is still actual.

Win 7 Pro 64-bit Version:
Build ID: 437210d58f32177ef1829d704f7f4d2f1bbfbfdd
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-18_07:21:56
Locale: fi-FI (fi_FI)