Bug 60845 - changed directory structure in LO 4 blocks Bibus reference manager
Summary: changed directory structure in LO 4 blocks Bibus reference manager
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: framework (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-14 14:59 UTC by Oliver
Modified: 2013-06-03 12:24 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver 2013-02-14 14:59:19 UTC
Bibus is a freeware reference manager software that has been running with OpenOffice and now Libreoffice for years to insert references into documents
http://sourceforge.net/projects/bibus-biblio/

Recent changes in the directory structure of Libreoffice have however blocked Bibus working with LO.
in the step from LibreOffice 3.4 to 3.5, the 
oobasis=C:\Program Files (x86)\LibreOffice 3.4\Basis\program
directory had disappeared, and Bibus seems to need access to this directory to work.
with some playing around I managed to get Bibus to run when pointing the oobasis to 
oobasis=C:\Program Files (x86)\LibreOffice 3.5\program

This did also work with LO 3.6

However, now with LO 4, something seems to have changed again with the Lo directory structure and trial and error does not seem to get me anywhere. 

Could anybody post here please what files had been in the old "Basis" directory and into which directory they have been put now ? 

Or can a programmer have a look into the sourcecode available on sourceforge and check why Bibus needs this access (Bibus is written in Python) ? The original programmer of Bibus does not seem to maintain, even though there are many users. 

Thanks very much in advance. 

Oliver
Comment 1 Julien Nabet 2013-02-16 19:00:31 UTC
Here's a bug opened on sourceforge about this:
http://sourceforge.net/tracker/?func=detail&aid=3603933&group_id=110943&atid=657832

Michael: how this tracker should be considered? Our bug or not? (ideally a dev may give an help to Bibus author but with 4.0 released...)
Comment 2 Petr Mladek 2013-02-25 10:51:00 UTC
LO-4.0 started to bundle python-3.3 instead of python-2.6. They are not fully compatible and python extensions might need some updates. I guess that this is the root of the problem why the extensions does not work in 4.0.

Regarding the missing Basis directory. LO has stopped using the unnecessary complex 3-layer structure since LO-3.5. I am not sure it other extensions needed an update for this. I think that it might be a design problem of the extension if it depends on it. Stephan?

All in all, it probably has to be fixed on the extensions side. In each case, a non-working 3rd party extension can't block the next bugfix release with many other useful fixes => reducing the severity a bit.
Comment 3 Oliver 2013-02-26 10:32:40 UTC
I'm not sure that the passage of LO to Python 3 is the problem : 
I have Python 2.6.1 installed on my Win7 computer and Bibus is using this to run. 
Also, the problem is not that the connection between Bibus and LO is not working, but that Bibus is not finding the presence of LO. Once Bibus is detecting LO, we can check if the UNO bridge is still working. 
And I think that here the problem is that Bibus is looking for some files, which might not exist anymore in the new installation or are somewhere else. 
As already described, I had exactly the same problem between LO3.4 and LO3.5 and managed to get Bibus to detect LO by playing around with the directories in the Bibus config file. 
I agree that this probably needs to be fixed on the extension side.
But as the original programmes is not very active ....
Cheers

Oliver
Comment 4 Joel Madero 2013-03-21 18:29:57 UTC
this honestly does not seem like our bug at all, we changed our structure for particular reasons, if outside software wishes to be compatible they need to update with us. We cannot or should not be expected not to make changes for fear of other software being incompatible.

Of course just my opinion, I would close this as NOTABUG but I'll leave it in the hands of Petr & Julien
Comment 5 Julien Nabet 2013-03-21 19:42:32 UTC
Joel: It seems we're all agree with this, since it's extension side, let's update the status to NOTOURBUG.
Moreover, if they need help/advice/etc. bibus mainteners may contact LO devs.
Comment 6 Oliver 2013-03-22 08:32:52 UTC
I would just like to comment that in my original post I have not at all asked for any changes in LibreOffice, I had just asked for some information on how the directory structure had changed between the last two version of LibreOffice, as I have not found any detailed information on this on publicly available webpages of LibreOffice. 
I agree totally that it is the responsibility of outside software to update for compatibility. 
However LibreOffice programmers could facilitate this by providing information on changes ;-)

Cheers

Oliver
Comment 7 Stephan Bergmann 2013-03-22 09:20:42 UTC
(In reply to comment #6)
> I would just like to comment that in my original post I have not at all
> asked for any changes in LibreOffice, I had just asked for some information
> on how the directory structure had changed between the last two version of
> LibreOffice, as I have not found any detailed information on this on
> publicly available webpages of LibreOffice. 
> I agree totally that it is the responsibility of outside software to update
> for compatibility. 
> However LibreOffice programmers could facilitate this by providing
> information on changes ;-)

Nothing "obvious" (like the drop of the basis directory in the past) changed recently, so without having more detailed information on how Bibus started to fail, it is not possible for me to provide you with meaningful information.  I would really like to help, but simply do not have the time to investigate into why Bibus started to fail myself.
Comment 8 Steve Murphy 2013-05-31 13:23:18 UTC
Hi Oliver,

I have Bibus v1.5.2 working with LO 4.0.2.2 from Ubuntu repositories on Ubuntu 12.10 64bit.

What symptoms are you getting?

Best regards,

Steve
Comment 9 Oliver 2013-05-31 14:21:39 UTC
Hello Steve, 
this is mostly described in my first post. 
The symptom is that Bibus is not "seeing" LibreOffice, neither from the menus nor from the first connection wizard. So basically, my guess is that the UNO connection is not working because Bibus is not able to access the right directory / files of Libreoffice. Some of these paths (as shown in my first post) are hardcoded into the bibusOOo.cfg file 
However compared to you, I run all of this under Windows 7; on the bibus forum I have found reports of Bibus working with LIbreOffice 4, these were also, as you are, on Ubuntu.
So I guess it's a Windows specific problem and so might be connected to differences in the setup of Libreoffice between.
If you have any ideas of what to test, they are very welcome. I think most of the Bibus community (including the main programmer) is working under Ubuntu, so there is not much response from them on this problem

Cheers

Oliver
Comment 10 Steve Murphy 2013-05-31 16:03:38 UTC
Hi Oliver,

When this occurs, I find that setting Macro Security to Medium (as the the macros needed are unsigned) and locating the file UnoConnectionListener.odg and running it tends to fix the problem.  The file is in the bibus/setup directory on my system and contains instructions inside it on how to use it.

Once done, restart LO and the link between LO and Bibus should be restored.

Hope that helps.

Best regards.

Steve
Comment 11 Oliver 2013-06-03 11:02:49 UTC
Dear Steve, 
its not a problem of the uni connection itself, I had chacked the uno connection using the UnoConnectionListener.odg and this works quite fine. 

As I have described before, Bibus is looking for something in the "basis" directory, which has now disappeared. 
However I don't know for what Bibus was looking in the Basis directory that it needs for the connection between LibreOffice and Bibus. 


Cheers

Oliver
Comment 12 Oliver 2013-06-03 11:50:39 UTC
It has probably something to do how Bibus "finds "Libreoffice" as when I'm runnin the first connection wizard, on the first page Bibus offers a liste to choose ones preferred wordprocessor; I get only greyed out options (not surprising for MSWord and LyX, as I don't have these installed) and the only choice is "None".

This would suggest that during the start of this wizard Bibus is checking the system for the different word processors, and is not finding LibreOffice.
Even though the path in both bibus.cfg and BibusOoo.cfg was changed to the new LibreOffice installation : 


oopath=C:\Program Files (x86)\LibreOffice 4.0\program
ooure=C:\Program Files (x86)\LibreOffice 4.0\URE\bin
oobasis=C:\Program Files (x86)\LibreOffice 4.0\share


when setting oobasis to 
oobasis=C:\Program Files (x86)\LibreOffice 4.0\program

Bibus won't start at all


with the last "normally" working version LO 3.5, this has been : 

oopath=C:\Program Files (x86)\LibreOffice 3.5\program
ooure=C:\Program Files (x86)\LibreOffice 3.5\URE\bin
oobasis=C:\Program Files (x86)\LibreOffice 3.5\Basis\program

from then on (that is wiht LO 3.6) I had to set oobasis to 
oobasis=C:\Program Files (x86)\LibreOffice 3.6\share

to get things working.

However this seems not to be working anymore. 
So perhaps something has changed in the "share" directory ??


Cheers

Oliver
Comment 13 Stephan Bergmann 2013-06-03 12:24:53 UTC
(In reply to comment #12)

"Basis" was a concept from OOo being split into three layers, URE, basis, and brand, that has long since been removed from LO, at least since LO 3.5.  There should be no need for an application to have any deep knowledge about the layout of a LO installation though.  All it should need to know is the path to the program directory containing the soffice and unoinfo executables.

That Bibus, which apparently expects LO to still use that basis concept ("oobasis"), happened to work when pointing oobasis to the share directory sounds like mere luck.  Looks like some Bibus developer should look into how that application interacts with a LO installation, and get that cleaned up (where help can generally be found at the resources listed at the top of <https://www.libreoffice.org/developers-2/>).