Download it now!
Bug 60899 - FILEOPEN: When opening XLSB file, Calc closes (crashes) without error message
Summary: FILEOPEN: When opening XLSB file, Calc closes (crashes) without error message
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Vangel Ajanovski
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-15 14:08 UTC by Vangel Ajanovski
Modified: 2014-10-05 23:02 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Test file that does not open (248.43 KB, application/vnd.ms-excel.sheet.binary.macroEnabled.12)
2013-02-15 15:19 UTC, Vangel Ajanovski
Details
bt with 3.6 sources (59.60 KB, text/plain)
2013-02-16 14:16 UTC, Julien Nabet
Details
console bt on master (19.24 KB, text/plain)
2013-09-25 20:34 UTC, Julien Nabet
Details
This file does not open - calc crashes without an error message (252.48 KB, application/vnd.ms-excel.sheet.binary.macroenabled.12)
2014-10-05 16:02 UTC, Vangel Ajanovski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vangel Ajanovski 2013-02-15 14:08:23 UTC
Problem description: 

I am trying to open an XLSB file and Calc crashes (all windows close by themselves) without any error information. No error is printed if started from command line.

Steps to reproduce:
1. Open the file from file manager or from command line or via File/Open within Calc.
2. After few seconds Libreoffice closes completely
              
Operating System: Linux (Other)
Version: 3.6.5.2 release
Comment 1 Vangel Ajanovski 2013-02-15 15:19:41 UTC
Created attachment 74875 [details]
Test file that does not open
Comment 2 Julien Nabet 2013-02-16 14:16:10 UTC
Created attachment 74939 [details]
bt with 3.6 sources

On pc Debian x86-64 with 3.6 sources updated some days ago, I reproduced the crash.
I noticed this line repeated several times:
warn:legacy.osl:5554:1:/home/julien/compile-libreoffice/libo_3_6/sc/source/filter/oox/stylesbuffer.cxx:2798: CellStyleBuffer::finalizeImport - multiple styles with equal built-in identifier

With 4.0 sources and master, I don't reproduce this.
Comment 3 Julien Nabet 2013-02-16 14:18:10 UTC
Kohei/Markus/Eike: do you know if there's one or several commits to cherry pick so it's ok on 3.6 too?
Comment 4 QA Administrators 2013-09-24 01:59:05 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 5 Vangel Ajanovski 2013-09-24 08:44:37 UTC
I think the last comment is misdirected towards me, as a bug reporter, since the information that was requested was not asked from me, nor I am in position to have that information.
Comment 6 Vangel Ajanovski 2013-09-24 08:45:45 UTC
This problem is fixed in 4.x
Comment 7 Urmas 2013-09-24 10:11:24 UTC
There is a "General IO error" message in master instead.
Comment 8 Julien Nabet 2013-09-25 20:34:02 UTC
Created attachment 86599 [details]
console bt on master

With LO Debian package 4.1.1.2, I don't have any problem.

With master sources updated yesterday, I got the crash attached.
Comment 9 Julien Nabet 2013-12-04 18:37:55 UTC
jgv: version corresponds to the earliest LO version in which you can reproduce the problem, see https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Version
Comment 10 Jan Vejlstrup 2013-12-05 07:17:10 UTC
Bug 60899

Hello

I downloaded version 4.1.3.2 and now it works.

Thank you very much.

Best regards

Jan Grove Vejlstrup
Comment 11 Jan Vejlstrup 2013-12-05 07:20:57 UTC
Hello

I downloaded version 4.1.3.2 and now it works.

Thank you very much.

Best regards

Jan Grove Vejlstrup
___________________________________________________
Jan Grove Vejlstrup
WEMAG Consulting AG
Bernstrasse 99, Postfach
CH-3122 Kehrsatz

Tel.:   +41 31 960 36 36
Fax:    +41 31 960 36 37
mail:   jgv@wemag.ch

Am 04.12.2013 19:37, schrieb bugzilla-daemon@freedesktop.org:
> Julien Nabet <mailto:serval2412@yahoo.fr> changed bug 60899 
> <https://bugs.freedesktop.org/show_bug.cgi?id=60899>
> What 	Removed 	Added
> Version 	4.0.6.2 release 	3.6.5.2 release
>
> *Comment # 9 <https://bugs.freedesktop.org/show_bug.cgi?id=60899#c9> 
> on bug 60899 <https://bugs.freedesktop.org/show_bug.cgi?id=60899> from 
> Julien Nabet <mailto:serval2412@yahoo.fr> *
> jgv: version corresponds to the earliest LO version in which you can reproduce
> the problem, seehttps://wiki.documentfoundation.org/QA/Bugzilla/Fields/Version
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You are on the CC list for the bug.
>
Comment 12 Eike Rathke 2013-12-05 16:57:00 UTC
No crash in master either, let's close this then.
Comment 13 Vangel Ajanovski 2014-10-05 16:02:46 UTC
Created attachment 107359 [details]
This file does not open - calc crashes without an error message
Comment 14 Vangel Ajanovski 2014-10-05 16:05:00 UTC
Also, the original test file I have submitted to this bug in Comment 1, that was working one month ago, now it doesn't work again in recent version of Libreoffice.

Tested in:
Version: 4.3.2.2.0+
Build ID: 4.3.2.2 Arch Linux build-1
Comment 15 Vangel Ajanovski 2014-10-05 16:08:01 UTC
Changed reported version number.
Comment 16 Julien Nabet 2014-10-05 17:16:33 UTC
On pc Debian x86-64 with 4.3.2.2 LO Debian package, I could open both files (with and without enabling macros).

Could you launch from console and see if there's any error/warn messages?

Also, for the test, could you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile) and give it a new try?
Comment 17 Vangel Ajanovski 2014-10-05 18:08:21 UTC
(In reply to Julien Nabet from comment #16)
> On pc Debian x86-64 with 4.3.2.2 LO Debian package, I could open both files
> (with and without enabling macros).
> 
> Could you launch from console and see if there's any error/warn messages?
> 
> Also, for the test, could you rename your LO directory profile (see
> https://wiki.documentfoundation.org/UserProfile) and give it a new try?

I did not think about this possibility.

Now that you mentioned it, I tried again with a clean profile and both files did open.

Thanks, obviously the problem is somewhere in the profile, I will try to find out what exactly and report this.
Comment 18 Vangel Ajanovski 2014-10-05 18:55:56 UTC
After many tries with the old profile and with a clear profile, this is what happens.

A with a cleared profile it opens instantly without problems

B if I put the profile back it fails, but there are three alternatives how it fails. I check this from command line:

B1. most of the times it fails very fast at arround 70% of opening with no error message whatsoever

B2. rarely it gets stuck, so it has to be killed

B3. rarely it fails with only this: *** Error in `/usr/lib/libreoffice/program/soffice.bin': 

B4. once in 50 tries it was able to open the file. but only once, it did not happen again.

B5. rarely i get this stack trace

$ libreoffice --calc test2.xlsb 
*** Error in `/usr/lib/libreoffice/program/soffice.bin': munmap_chunk(): invalid pointer: 0x00000000039ed2d8 ***
======= Backtrace: =========
/usr/lib/libc.so.6(+0x7340e)[0x7f9795ea540e]
/usr/lib/libc.so.6(+0x7884e)[0x7f9795eaa84e]
/usr/lib/libreoffice/program/../ure-link/lib/libuno_cppu.so.3(uno_any_destruct+0x190)[0x7f9794a1e710]
/usr/lib/libreoffice/program/../program/libscfiltlo.so(+0x301ff4)[0x7f975e745ff4]
/usr/lib/libreoffice/program/../program/libscfiltlo.so(+0x302272)[0x7f975e746272]
/usr/lib/libreoffice/program/../program/libscfiltlo.so(+0x308707)[0x7f975e74c707]
/usr/lib/libreoffice/program/../program/libscfiltlo.so(+0x2ff821)[0x7f975e743821]
/usr/lib/libreoffice/program/../program/libscfiltlo.so(+0x34dc9d)[0x7f975e791c9d]
/usr/lib/libreoffice/program/../program/libscfiltlo.so(+0x34e426)[0x7f975e792426]
/usr/lib/libreoffice/program/../program/libscfiltlo.so(+0x34ed48)[0x7f975e792d48]
/usr/lib/libreoffice/program/../program/libooxlo.so(_ZN3oox4core21ContextHandler2Helper23implCreateRecordContextEiRNS_19SequenceInputStreamE+0xa)[0x7f9774bc493a]
/usr/lib/libreoffice/program/../program/libooxlo.so(_ZN3oox4core15ContextHandler219createRecordContextEiRNS_19SequenceInputStreamE+0xd)[0x7f9774bc494d]
/usr/lib/libreoffice/program/../program/libooxlo.so(+0x10a7fa)[0x7f9774bd87fa]
/usr/lib/libreoffice/program/../program/libooxlo.so(_ZN3oox4core13XmlFilterBase14importFragmentERKN3rtl9ReferenceINS0_15FragmentHandlerEEERNS0_10FastParserE+0x2b4)[0x7f9774be0f14]
/usr/lib/libreoffice/program/../program/libscfiltlo.so(+0x374c0d)[0x7f975e7b8c0d]
/usr/lib/libreoffice/program/../program/libscfiltlo.so(+0x368d27)[0x7f975e7acd27]
/usr/lib/libreoffice/program/../ure-link/lib/libuno_salhelpergcc3.so.3(_ZN9salhelper6Thread3runEv+0x16)[0x7f97940a0e66]
/usr/lib/libreoffice/program/../ure-link/lib/libuno_salhelpergcc3.so.3(+0x40da)[0x7f97940a10da]
/usr/lib/libreoffice/program/../ure-link/lib/libuno_sal.so.3(+0x149df)[0x7f979645d9df]
/usr/lib/libpthread.so.0(+0x7314)[0x7f9795c1d314]
/usr/lib/libc.so.6(clone+0x6d)[0x7f9795f1a3ed]
======= Memory map: ========
00400000-00401000 r-xp 00000000 08:06 3035826                            /usr/lib/libreoffice/program/soffice.bin
00600000-00601000 r--p 00000000 08:06 3035826                            /usr/lib/libreoffice/program/soffice.bin
00601000-00602000 rw-p 00001000 08:06 3035826                            /usr/lib/libreoffice/program/soffice.bin
021bd000-04106000 rw-p 00000000 00:00 0                                  [heap]
....
Comment 19 Julien Nabet 2014-10-05 19:00:34 UTC
Vangel: quite often the problem is in registrymodifications.xcu file.
Now, it could also be for example:
- a specific extension (from a clean profile, you can try to install the extension 1 by 1 - or n by n if you really have got a lot of them)
- a Java upgrade which isn't well taken into account.

So you can first try with a clean LO profile + registrymodifications.xcu from the "buggy" profile.
Comment 20 Vangel Ajanovski 2014-10-05 21:54:43 UTC
(In reply to Julien Nabet from comment #19)
> Vangel: quite often the problem is in registrymodifications.xcu file.

The problem is here. If I delete the file everything is OK.

I guess I am loosing some settings with this, but I don't know what since the list of differences is huge, so I don't know if this classifies as a solution.

So, When I find the problematic lines, I will report it.
Comment 21 QA Administrators 2014-10-05 23:02:52 UTC
Setting this to WFM since it is specific to your profile. If you want to attach your entire profile please report a new bug that just has a clean description and your profile zipped so others can test it. These are particularly hard to diagnose since they are specific to the users settings :/ Thanks