Bug Hunting Session
Bug 61037 - VIEWING: Selection is not visible while scrolling
Summary: VIEWING: Selection is not visible while scrolling
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.0.2 rc
Hardware: All Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-18 03:40 UTC by Plavozont
Modified: 2018-01-25 11:49 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
While I was making this screenshot I got that I can look at the column with row numbers to find the edge :) And still I would love to look at the normal selection while I scroll, and who knows how many people stumble like this. (171.80 KB, image/jpeg)
2013-02-18 03:40 UTC, Plavozont
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Plavozont 2013-02-18 03:40:22 UTC
Created attachment 75020 [details]
While I was making this screenshot I got that I can look at the column with row numbers to find the edge :) And still I would love to look at the normal selection while I scroll, and who knows how many people stumble like this.

Problem description: 

For example I have a large table.

Steps to reproduce:
1. I want to select somwhere in the middle of it a large block and make an autofilter on it.
2. I have to scroll to the first cell where selection starts, select it, scroll to the the last cell, shift+select it.
3. Then create autofilter.
4. Next step obviously is to get to the beginning of selection to actually use the autofilter.

Current behavior:
I cannot see the selection while I scroll.

Expected behavior:
I need to see it, either way it would be a struggle to get to the top edge of it

Conclusion:
If rendering of the selection rectangle inside the table rendering system slows up scrolling(or whatever made you render it like this) then make an option that changes the rendering way for those people who will find it more acceptable

Operating System: Windows XP
Version: 4.0.0.3 release
Comment 1 ntrrgc 2013-04-09 18:29:54 UTC
You can also see the selection bounds (textually) on the range bar, at the left of formula bar.

Anyway, I identify two usability issues here:

1. Selection borders may be too thin.

   This is not really important if you have an all white background sheet, but on more colored sheets like yours, it may result hard to find the selection bounds.

   The issue gets aggravated when using custom cell borders.

2. It is hard to reach selection bounds though it is a common need (i.e. when performing autofilter).

   As far as I know, the only way to reach them is manually using the scrollbar.

   It would be handy to have some keyboard shortcuts for things like:

   * Move (or maybe scroll?) to the leftmost cell within selection (row will be kept).
   * Move (or maybe scroll?) to the topmost cell within selection (column will be kept).
   * The same for rightmost and bottommost cells.

Somebody could CC someone from the UX team for ideas?
Comment 2 tagezi 2018-01-22 11:50:18 UTC
We no longer support Windows XP. Is there issue now on other OS?
I can not confirm it on Kubuntu 16.04 in LO 6.0
Comment 3 Plavozont 2018-01-23 01:53:51 UTC
I have a faster PC now with intel i5 proc and windows 10 (tested in LO 6.0.0.2 and LO 5.4.4). The selection is blinking while scrolling but frequently enough to not get lost at all. On slower PCs it would be the same as before.


Another bug I noticed:

Start LO calc, make window size half screen(not maximized). Select all. Maximize window.

Selection will stay same size as it was when window was not maximized. However column's letters and row's numbers are highlighted correctly(Same both in LO 6.0.0.2 and LO 5.4.4).
Comment 4 Xisco Faulí 2018-01-23 08:30:34 UTC
> Another bug I noticed:
> 
> Start LO calc, make window size half screen(not maximized). Select all.
> Maximize window.
> 
> Selection will stay same size as it was when window was not maximized.
> However column's letters and row's numbers are highlighted correctly(Same
> both in LO 6.0.0.2 and LO 5.4.4).

Could you please report it in a new ticket ?