Download it now!
Bug 61039 - FORMATTING: Increase/decrease font size should work on different sizes at once (see comment 8)
Summary: FORMATTING: Increase/decrease font size should work on different sizes at onc...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Font-Size
  Show dependency treegraph
 
Reported: 2013-02-18 05:23 UTC by Jiero
Modified: 2018-10-29 10:08 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot about how to set a percent for the font size. (227.00 KB, image/png)
2013-02-19 23:30 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiero 2013-02-18 05:23:30 UTC
I want a fast way to scale up/down every piece of text in the document.

Steps to reproduce:
Drag or set percentage
All font sized changed


Current behavior:

Style Not bounded

Expected behavior:

A way to change font size all together. Useful if export to ebook reader, kindle or tablet pc.
Operating System: All
Version: 4.1.0.0.alpha0+ Master
Comment 1 Joel Madero 2013-02-18 19:15:39 UTC
Valid enhancement request. Marking as such.

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
New (valid request)
Enhancement (not a bug, just not a feature we currently have)
Medium (could be quite useful
Comment 2 m.a.riosv 2013-02-19 23:30:47 UTC
Created attachment 75139 [details]
Screenshot about how to set a percent for the font size.

Hi Jiero,

Maybe not all what you want, but is possible to set a percent in the styles.
See the attached screenshot.
Comment 3 Jiero 2013-02-20 03:19:06 UTC
Hi marlosv,
I knew it is possible to set style by style; but a way to set all styles
together in use is preferred.

Regards,
Jiero



On Wed, Feb 20, 2013 at 7:30 AM, <bugzilla-daemon@freedesktop.org> wrote:

>   *Comment # 2 <https://bugs.freedesktop.org/show_bug.cgi?id=61039#c2> on bug
> 61039 <https://bugs.freedesktop.org/show_bug.cgi?id=61039> from mariosv<mariosv@miguelangel.mobi>
> *
>
> Created attachment 75139 [details] <https://bugs.freedesktop.org/attachment.cgi?id=75139> [details] <https://bugs.freedesktop.org/attachment.cgi?id=75139&action=edit>
> Screenshot about how to set a percent for the font size.
>
> Hi Jiero,
>
> Maybe not all what you want, but is possible to set a percent in the styles.
> See the attached screenshot.
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 4 mahfiaz 2013-02-21 10:14:38 UTC
Since all styles are substyles of "Default" style, then I believe we already have this feature.
Comment 5 Jiero 2013-02-21 11:13:09 UTC
Then please make it easier to access.


On Thu, Feb 21, 2013 at 6:14 PM, <bugzilla-daemon@freedesktop.org> wrote:

>   *Comment # 4 <https://bugs.freedesktop.org/show_bug.cgi?id=61039#c4> on bug
> 61039 <https://bugs.freedesktop.org/show_bug.cgi?id=61039> from Mattias
> Põldaru <mahfiaz@gmail.com> *
>
> Since all styles are substyles of "Default" style, then I believe we already
> have this feature.
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 6 mahfiaz 2013-03-01 09:40:44 UTC
That's a fair suggestion. How would you suggest how it is easily accessible? 

Default template already using percentage sizes?

Have an extra template which has percentage sizes? Maybe just have it online? All you would have to do is download and use it. And if you already started with your document, you could copy your text over.

Format dialog having extra button to change between percentage and size values? Would actually be useful if it preserved the real size, e.g parent size is 12px, we have 14px size, button converts it into 117% or back.
Comment 7 Mike Kaganski 2016-12-11 15:10:10 UTC
Isn't Format->Text->Increase/Decrease Size (Ctrl+]/[) the thing that is sought for?
Comment 8 Claudio Nieder 2017-12-06 18:53:41 UTC
(In reply to Mike Kaganski from comment #7)
> Isn't Format->Text->Increase/Decrease Size (Ctrl+]/[) the thing that is
> sought for?

Unfortunately not. LEt's says you have a sentence where some words are size 10 some are size 12 and some are size 14 and you select the whole sentences and then perform the Increase size. You then end up with a sentence where all words have the same size. I just tried this today in LibreOffice version 5.4.3.2
Comment 9 Mike Kaganski 2017-12-06 19:10:20 UTC
(In reply to Claudio Nieder from comment #8)
> Unfortunately not. LEt's says you have a sentence where some words are size
> 10 some are size 12 and some are size 14 and you select the whole sentences
> and then perform the Increase size. You then end up with a sentence where
> all words have the same size. I just tried this today in LibreOffice version
> 5.4.3.2

I'd say it's a bug then.
Comment 10 Thomas Lendo 2018-10-28 22:37:05 UTC
Changing summary from "FORMATTING: Propotional Font Size Scaling Support - may be easier?" to "FORMATTING: Increase/decrease font size should work on different sizes at once" as this is the core issue here.
Comment 11 Mike Kaganski 2018-10-29 05:50:59 UTC
(In reply to Claudio Nieder from comment #8)
> LEt's says you have a sentence where some words are size
> 10 some are size 12 and some are size 14 and you select the whole sentences
> and then perform the Increase size. You then end up with a sentence where
> all words have the same size. I just tried this today in LibreOffice version
> 5.4.3.2

Cannot reproduce with Version: 6.1.3.1 (x64)
Build ID: a9670562c26181ec3afbe381c9ff499ae88c98b7
CPU threads: 12; OS: Windows 10.0; UI render: GL; 
Locale: ru-RU (ru_RU); Calc: CL

Creating a sentence of 3 words, ne size 10, one 12, and one 14, selecting the sentence, and using Ctrl+[/] changes sizes to be 12, 14, and 16 resp. after one increase, or 8, 10, and 12 after one decrease.
Comment 12 Thomas Lendo 2018-10-29 10:08:02 UTC
I also can't reproduce the problem described in comment 8.

Version: 6.2.0.0.alpha1+ (x64)
Build ID: 59d48c531a5cad27f02b91c9b86278d5ede211a1
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-10-29_01:05:52
Locale: de-AT (de_AT); Calc: CL

Therefore I close this bug as WORKSFORME.

There are many ways to increase and decrease fonts, with styles or without. Also this bug was hijacked by many ideas and solutions.

But because I understand the core request of comment 0 ("Drag or set percentage > All font sized changed"), I'll create two follow up bugs that can be discussed.

See also:
Bug 121008 - FORMATTING: Font size command should allow percentage value
Bug 121011 - FORMATTING: Make font size field in styles dialogs toggleable between percentage and pt