Download it now!
Bug 61040 - VIEWING wrong for gradients (from Templates) in ODF 1.2 Extended
Summary: VIEWING wrong for gradients (from Templates) in ODF 1.2 Extended
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: odf_validation
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-18 07:41 UTC by Yorick Bosman
Modified: 2015-03-22 12:08 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Contains source files made in 3.6.5 and 4.0.0.3 and the exports in pdf from both versions. (633.19 KB, application/zip)
2013-02-18 07:41 UTC, Yorick Bosman
Details
Test Kit (633.19 KB, application/x-zip-compressed)
2013-02-18 12:41 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yorick Bosman 2013-02-18 07:41:49 UTC
Created attachment 75031 [details]
Contains source files made in 3.6.5 and 4.0.0.3 and the exports in pdf from both versions.

When applying the "Lush green" master template to a slide. The rendering of the Template isn't what it's should be.

I've added the odp file and a pdf export of Libreoffice 3.6.5 and 4.0.0.3.

I've just updated to 4.0 without removing 3.6.5 first.
Removing 4.0 and reinstalling 3.6.5 temporally fixes it when creating a new file. Not when editing an already saved file in 4.0!
Comment 1 Rainer Bielefeld Retired 2013-02-18 11:54:03 UTC
I believe it 's a more general Gradient transparency + whatever issue.

Steps how to reproduce with Server Installation of "LibO  4.0.0.3   -  GERMAN UI / German Locale  [Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89)]"  {tinderbox: @6, pull time 2013-01-31 11:30(?)} on German WIN7 Home Premium (64bit) with separate  new User Profile:

0. Launch LibO
1. Menu 'File -> Wizards -> Presentation -> From Template - Lush Green <Create>'
   Expected: At top of page horizontal green bar over all page width,  1/5 page
            height (with gradient), below for rest of page height 
            light grey rectangle
   Actual: Green area with additional green, blue, pink color dsegments,
           grey area shows concentric grey ellipse areás

Some more research will be necessary
Comment 2 Rainer Bielefeld Retired 2013-02-18 12:38:56 UTC
Might be an ODF validity problem.

In attached Test kit you will find 3 Templates.

LushGreen_4003.otp
-------------------
This is the original tempate from OOo 4.0.0.3
LibO 3.6.5.3: opens fine
LibO 4.0.0.3: shows wrong view due to reporter's "libreoffice-4.0.0.3.pdf"

LushGreen_4003_365_extendedodf.otp
-----------------------------------
Has been created from "LushGreen_4003.otp" using LibO 3.6.5: I saved the document with ODF compatibility setting "1.2 Extended"
LibO 3.6.5.3: opens fine
LibO 4.0.0.3: shows wrong view due to reporter's "libreoffice-4.0.0.3.pdf"

LushGreen_4003_365_strictodf.otp
---------------------------------
Has been created from "LushGreen_4003.otp" using LibO 3.6.5: I saved the document with ODF compatibility setting "1.2" (= strict)
LibO 3.6.5.3: opens fine
LibO 4.0.0.3: opens fine

drawingstrict_365.odg
---------------------
Drawing created from LibO 3.6 with Background picture from Template "Lush green", saved with strict 1.2 ODF
LibO 3.6.5.3: opens fine
LibO 4.0.0.3: opens fine

drawingextended_365.odg
---------------------
Drawing created from LibO 3.6 with Background picture from Template "Lush green", saved with Extended 1.2 ODF
LibO 3.6.5.3: opens fine
LibO 4.0.0.3: shows wrong view due to reporter's "libreoffice-4.0.0.3.pdf"


I did an additional test with the LushGreen.otp I find in the 3.6.5 installation: Same problems with 4.0.0.3

So the problem is not in the template, but a problem with tolerance concerning Extended ODF 1.2 

Also affected Presentation Templates: Abstract Yellow and may be others with other effects
Comment 3 Rainer Bielefeld Retired 2013-02-18 12:41:59 UTC
Created attachment 75043 [details]
Test Kit

See Comment before how to use
Comment 4 Francis Devereux 2013-04-24 12:56:27 UTC
Reproduces for me in LibreOffice 4.0.2.2 (Build ID 4c82dcdd6efcd48b1d8bba66bfe1989deee49c3) on Mac OS X 10.8.3, so it seems it is not specific to Windows.
Comment 5 QA Administrators 2015-03-04 02:18:37 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1.2 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-03-03
Comment 6 Buovjaga 2015-03-22 12:08:21 UTC
(In reply to Rainer Bielefeld Retired from comment #1)
> 0. Launch LibO
> 1. Menu 'File -> Wizards -> Presentation -> From Template - Lush Green
> <Create>'
>    Expected: At top of page horizontal green bar over all page width,  1/5
> page
>             height (with gradient), below for rest of page height 
>             light grey rectangle
>    Actual: Green area with additional green, blue, pink color dsegments,
>            grey area shows concentric grey ellipse areás

No problem anymore -> WFM.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI