Bug 61055 - Writer does not parse (and import) complex SVG-Path correctly
Summary: Writer does not parse (and import) complex SVG-Path correctly
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-18 11:08 UTC by bugs
Modified: 2015-02-11 20:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
SVG-File to import via Insert->Image->from File (47.96 KB, image/svg+xml)
2013-02-18 11:08 UTC, bugs
Details
ODT-File (34.35 KB, application/vnd.oasis.opendocument.text)
2013-02-18 11:10 UTC, bugs
Details
My results (88.51 KB, image/png)
2013-03-15 17:44 UTC, Florian Reisinger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugs 2013-02-18 11:08:09 UTC
Created attachment 75039 [details]
SVG-File to import via Insert->Image->from File

Writer does not parse (and import) small and complex svg-paths correcty (smoothly). This causes "unsharp" prints. bigger paths are no problem.

The SVG-File does not seem to be the problem. Firefox or IE do displays the file correctly.

It is not an export-problem. The result for Printing directly, Printing to a PDF-Printer and exporting to PDF is the same.
Comment 1 bugs 2013-02-18 11:10:32 UTC
Created attachment 75040 [details]
ODT-File
Comment 2 Florian Reisinger 2013-03-15 17:44:01 UTC
Can't confirm a difference between GIMP LibO 4 and todays master @Win 7 x64 (Attaching Screenshot in a second). Please upload a screenshot as well....
Comment 3 Florian Reisinger 2013-03-15 17:44:26 UTC
Created attachment 76587 [details]
My results
Comment 4 bugs 2013-03-17 20:38:10 UTC
You only see it, if you zoom in to 600 - 1200%. it causes unsharp print results...
Comment 5 QA Administrators 2013-09-24 01:44:02 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 6 bugs 2013-09-24 15:41:05 UTC
see comment 4
Comment 7 bfoman (inactive) 2014-01-08 22:33:10 UTC
Improper status. Also as LibreOffice 4.0.x is in End Of Life state please recheck in latest stable version 4.1.4 and attach screenshot requested in comment 2 if bug is still reproducible.
Comment 8 bugs 2014-01-17 08:00:45 UTC
Problem still exists in 4.1.3.2
Comment 9 Matthew Francis 2014-12-04 07:37:35 UTC
I cannot reproduce this in 4.0.0.3 or current 4.5 master.

Setting a bug to NEW requires it to have been independently confirmed by another person, but I don't see that any of the previous commenters have done so, so setting this to NEEDINFO.


As previously commented, could the original submitter please attach an screenshot of the issue they see, then set the bug back to UNCONFIRMED (not NEW). Thanks.
Comment 10 QA Administrators 2015-02-11 20:01:07 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INVALID due to inactivity and a lack of information which is needed in order to accurately reproduce and confirm the problem. We encourage you to retest your bug against the latest release. If the issue is still present in the latest stable release, we need the following information (please ignore any that you've already provided):

a) Provide details of your system including your operating system and the latest version of LibreOffice that you have confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED and we will attempt to reproduce the issue. 

Please do not:
a) respond via email 
b) update the version field in the bug or any of the other details on the top section of FDO
Message generated on: 2015-02-11