Bug Hunting Session
Bug 61086 - Style error in calc
Summary: Style error in calc
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Calc-Styles
  Show dependency treegraph
 
Reported: 2013-02-18 21:32 UTC by Gergő Mocsi
Modified: 2018-10-25 22:24 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gergő Mocsi 2013-02-18 21:32:07 UTC
There is a style error in calc. 
- After installing (in my case, after build), open up a new spreadheet in calc.
- Set one cell's backgound manually (eg. for grey), and type something in it (eg. TEST) to see the changes.
- Now, choose a style (eg. the in-built Default). The text in the cell changes according to the selected style (Default), and the backgound remains grey.
- Click on the Heading style, to see it changing. After that, click on the Default style to restore the original state.
- Now, click on the Heading style with right mouse button (in Styles and Formatting window) -> Modify -> Background tab and without any change, press OK button.
- Now, apply Heading style on the cell: the cell's backgound becomes white: this is the error (we have set it to grey!!!!).
Comment 1 m.a.riosv 2013-02-19 01:48:12 UTC
Hi Gergö, thanks for reporting.

I can reproduce with:
Win7x64 Ultimate
Version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89)

Seems that Heading/Heading1 do not respect the manual background the other styles yes.
Comment 2 Joel Madero 2014-08-07 01:20:50 UTC
Removed regression as we don't have anyone who has claimed this ever worked and the version field is left as "unspecified"

If there was ever a version that worked please let us know what version and add regression in keywords
Comment 3 QA Administrators 2015-09-04 02:48:05 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2015-11-18 11:39:24 UTC
Still repro.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: b216cc1b8096eb60c27f67e8c27b7cd756c75e38
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-11-12_00:06:20
Locale: fi-FI (fi_FI)
Comment 5 QA Administrators 2017-01-03 19:36:07 UTC Comment hidden (obsolete)
Comment 6 Thomas Lendo 2018-10-25 22:24:10 UTC
Can't reproduce anymore, maybe because of the new cell styles a few versions ago.

Version: 6.2.0.0.alpha1+
Build ID: 0378bfcea51ff0f379d0954aa6740f1829909dc3
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: de-DE (de_DE.UTF-8); Calc: threaded

Closing bug as RESOLVED WORKSFORME.

If you still see this problem with version 6.2 or above, please reopen as NEW.