Bug Hunting Session
Bug 61110 - SLIDESHOW: Object z-order not preserved after "appear"-animation above formula object
Summary: SLIDESHOW: Object z-order not preserved after "appear"-animation above formul...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.7.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-19 11:09 UTC by saparvia
Modified: 2016-02-10 16:08 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
An example slide showing the problem. Start the presentation, and click twice to see the problem. (14.46 KB, application/vnd.oasis.opendocument.presentation)
2013-02-19 11:09 UTC, saparvia
Details

Note You need to log in before you can comment on or make changes to this bug.
Description saparvia 2013-02-19 11:09:34 UTC
Created attachment 75104 [details]
An example slide showing the problem. Start the presentation, and click twice to see the problem.

Problem description: 

Steps to reproduce:
1. Insert a formula (Insert -> Object -> Formula)
2. Add two rectangles above the formula, filled with a color to make the problem more visible
3. Add an Appear animation to both rectangles (Start on click)

Current behavior:
1. Click once, first rectangle appears above the formula
2. Second click, second rectangle appears above the formula, the first one moves below the formula.

Expected behavior:
The first rectangle should stay above the formula.



Operating System: Ubuntu
Version: 3.5.7.2 release
Comment 1 Thomas Arnhold 2013-02-19 12:29:36 UTC
Confirmed with: 3.6.3.2 and 3.6.5.2 (Fedora 18)

Not reproduced with: 4.0.0.3 on Windows 7 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89).
Comment 2 QA Administrators 2015-02-19 15:44:23 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.0.3 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-02-19
Comment 3 Buovjaga 2015-03-08 19:30:57 UTC
Reproduced.

Ubuntu 14.10 64-bit 
Version: 4.4.1.2
Build ID: 40m0(Build:2)
Locale: en_US
Comment 4 saparvia 2016-02-10 16:03:53 UTC
Seems to work correctly in LibreOffice 5.0.4.2
Comment 5 Buovjaga 2016-02-10 16:08:40 UTC
Thanks, let's set to WFM.