Download it now!
Bug 61184 - cinch window resizing doesn't work (possibly a11y problem?)
Summary: cinch window resizing doesn't work (possibly a11y problem?)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other Mac OS X (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-20 19:22 UTC by Luis Villa
Modified: 2017-08-26 12:31 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luis Villa 2013-02-20 19:22:39 UTC
Cinch is a small Mac utility (available for free download here: http://www.irradiatedsoftware.com/cinch/) that uses the Mac a11y interfaces to resize windows (similar to how modern GNOME and Windows will resize windows when they are dragged into a corner).

Cinch works with most apps, but does not work with LibreOffice. Filing this as "minor", but it should probably be evaluated, as it could indicate a serious problem with the a11y interfaces.
Comment 1 Jorendc 2013-04-15 22:04:57 UTC
Hi,

Thanks for reporting. I can reproduce this behavior using Mac OSX 10.8.3 with LibreOffice 4.0.2.2. 

I installed Cinch to test this bug. Dragging the window to the side of the screen, to let the window fill half of the screen, or drag it to the top to make it fill the full screen doesn't work. It works with other applications (tested with Firefox, Thunderbird and Word).

Therefore I mark this as NEW. Although I don't think it's likely this will be fixed soon, or even 'ever' (we don't have many developers who develops for Mac OSX).
There are also not that many users using this tool, so therefore I mark this as 'Minor Low'. I hope you can deal with that? Although all that, it is a great tool. Thanks for that :-). I'm going to use it too I guess :p.

Kind regards,
Joren
Comment 2 QA Administrators 2015-03-04 02:21:58 UTC Comment hidden (obsolete)
Comment 3 Alex Thurgood 2015-03-25 16:41:35 UTC
None of the commits since this was first reported deal with window management or tiling (except in the Android/iOS development perhaps, but different product), so nothing has changed on this front for LO on OSX.
Comment 4 Alex Thurgood 2015-03-25 16:43:19 UTC
Cinch is not a free tool - it costs $6.99 from the Apple online store
Comment 5 Alex Thurgood 2015-03-25 16:48:14 UTC
The latest version of Cinch (trial version) now has a pre-configured Ignore function for LibreOffice which is displayed when you click on LO window when Cinch is running. The error message reads :

LibreOffice is on a list of applications that don't work well with Cinch.  To provide the best experience, Cinch is ignoring this application to prevent any misbehavior.

Click the Help button for more information or contact support if you have any questions.
Comment 6 tommy27 2016-04-16 07:23:33 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2017-05-22 13:23:42 UTC Comment hidden (obsolete)
Comment 8 eisa01 2017-08-26 12:31:38 UTC
I installed the latest version of Cinch.

Cinch is able to resize LibreOffice windows for me when I disable the ignoring of LibreOffice in Cinch.

I have also never had problems with the similar app HyperDock that has the same functionality

Setting as Works for me

Version: 5.3.0.3
Mac OS X 10.12.6