Bug Hunting Session
Bug 61202 - Formula is hidden when window is inacitve
Summary: Formula is hidden when window is inacitve
Status: RESOLVED DUPLICATE of bug 81636
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-21 03:06 UTC by mahfiaz
Modified: 2018-10-28 23:07 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mahfiaz 2013-02-21 03:06:46 UTC
When I click a cell to see the formula, then click on another window where I write it down or take notes, the formula is hidden. I'd like it to remain visible.

To workaround this feature one would have to start editing the formula (double click the cell or place cursor inside input area), this makes it stay visible.

It probably is originally thought of as a feature, but for some cases this is counterproductive, as we just saw.
Comment 1 Joel Madero 2013-04-14 19:08:07 UTC
Hm, can you clarify where you're trying to see the formula, and when you say "click on another window" you just mean any other window (firefox for instance)?
Comment 2 mahfiaz 2013-04-14 21:13:45 UTC
Thank you for your question. It turns out that this "other window" has to be LibreOffice's, I tried Calc, Writer, Impress and Draw, all made the formula to be hidden. When I click on e.g LibreOffice Base or Firefox window, the formula remains visible.
Comment 3 Joel Madero 2013-04-16 16:11:59 UTC
Thank you for reporting this enhancement request! I can confirm that this is a valid enhancement request on:
Version: 4.1.0.0.alpha0+Build ID: 6e3e6ef7257e93743a72719581ef6fe0016e58e
Date:   Thu Apr 11 15:24:38 2013 +0200 
Platform: Bodhi Linux 2.2 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 

As I've been able to confirm the enhancement request I am marking as:

New (confirmed)
Enhancement
Medium - default seems right

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 4 mahfiaz 2013-04-16 20:41:40 UTC
Thank you.

I believe the original hiding was considered as a feature by the implementator (since hiding it most likely requires some extra steps), but I fail to see how this could be actually useful. Maybe its to reduce clutter on screen, but on the other hand it causes more changes/flickering on screen, which should be avoided as well.
Comment 5 mahfiaz 2016-04-16 08:01:37 UTC
Still an issue in 5.1.2.1 (current fresh build).
Comment 6 Thomas Lendo 2018-10-28 23:07:09 UTC
I set this as dupe of the other bug despite it's newer but has more information.

*** This bug has been marked as a duplicate of bug 81636 ***