Download it now!
Bug 61286 - VIEWING: Wrong formula showing
Summary: VIEWING: Wrong formula showing
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-22 15:39 UTC by olafbond
Modified: 2015-03-12 06:09 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description olafbond 2013-02-22 15:39:29 UTC
Problem description: 

To put text starting from special symbols like "-" or "=" we should put sybol "'" first. And this symbol should not be visible. Now it is.


Operating System: Windows XP
Version: 3.6.5.2 release
Comment 1 Winfried Donkers 2013-04-18 07:32:46 UTC
I confirm behaviour on version 4.0.2 (Windows)

entering ['=DATE] (without []) in a cell shows the ' in front.
Comment 2 QA Administrators 2015-03-04 02:21:13 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1.2 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-03-03
Comment 3 Winfried Donkers (retired) 2015-03-04 06:39:43 UTC
Bug is still present in versions 4.3.6 and current master (4.5.0.0.alpha0+).
Comment 4 olafbond 2015-03-04 07:02:31 UTC
Still on 4.4.1.2
The way to avoid the issue is to apply format 'Text' to a cell and then reenter a text.
Comment 5 Jean-Baptiste Faure 2015-03-12 06:09:39 UTC
Not a bug for me. It always worked this way and it works as designed.
If you want to enter a text starting with = you only have to add a space before it. In other word, if the = sign is not the first character in the cell, it is not interpreted as a formula.
The quote is intended to say that a number must be seen as a character string.

Closing as NotABug. Please, feel free to reopen if you disagree. In such a case, please, explain why you think that is a bug.

Best regards. JBF