Download it now!
Bug 61300 - VIEWING: Missing vector art in drawing after pasting into Writer and saving and re-opening Writer document (affects connectors and textboxes)
Summary: VIEWING: Missing vector art in drawing after pasting into Writer and saving a...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-22 18:36 UTC by mitchfx
Modified: 2015-04-19 15:43 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Example of vector graphics not displaying connectors anymore in Write. After saving appears the vector art from LibreOffice Draw) are converted to a picture and information is lost. (14.00 KB, application/vnd.oasis.opendocument.text)
2013-02-22 18:36 UTC, mitchfx
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mitchfx 2013-02-22 18:36:56 UTC
Created attachment 75343 [details]
Example of vector graphics not displaying connectors anymore in Write. After saving appears the vector art from LibreOffice Draw) are converted to a picture and information is lost.

Problem description:
A drawing created in LibreOffice Draw, copied into LibreOffice Writer 4.0.0.3 (or similar version), does not properly display the drawing (in Writer) after saving, closing and re-opening the LibreOffice Writer document. Appears to be affecting connectors, textboxes and arrows. After saving appears the vector art from LibreOffice Draw) are converted to a picture and information is lost.


Steps to reproduce:
1. Create drawing in LibreOffice Draw (used vector graphics). Add connectors (connected to other shapes), textboxes and arrows since it appears to affect connectors, arrows, textboxes most often but may not be limited to only these objects.
2. Copy drawing into LibreOffice Writer. 
3. Centered drawing in Writer and changed anchor to "As Character" and added some text above and below like a typical figure in text document.
4. Can close the LibreOffice Draw drawing document now (save the drawing just to be able to repeat steps later if neccessary).
5. Save & close the LibreOffice Writer document with the text and drawing.
6. Re-open LibreOffice Writer document with text and drawing.
7. Inpect the drawing for missing vectors or objects.

Current behavior:
After saving and re-opening a Writer document with vector drawings done in LibreOffice draw, the drawing is missing some vector art when the Writer document is re-opened. Eg. drawing or graphic is not displayed properly (missing vectors such as connectors, arrows and textboxes). After saving appears the vector art from LibreOffice Draw) are converted to a picture and information is lost.

Expected behavior:
Expecting the drawing in Writer to save and display properly when re-opened in Writer (with all vectors and art showing properly).

              
Operating System: Windows 7
Version: 4.0.0.3 release
Comment 1 Joel Madero 2013-04-14 20:29:45 UTC
this is definitely a duplicate - I will try to find it and mark this one as such.
Comment 2 Joel Madero 2013-04-14 21:05:34 UTC
Okay I really can't find it but I know that it exists. Marking this one as NEW and prioritizing but be aware that it's a dupe.

Major - data loss
High - default for major bugs
Comment 3 melchiaros 2013-05-26 13:31:28 UTC
I have the same problem on Ubuntu Linux 13.04 raring 64bit. The launchpad report could be found at:

https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1181738

An example file is available there, also a in deep description.

The hader of the report will be copied here(version informations are also in it):
----------------------------------------------------------------

1) lsb_release -rd
Description: Ubuntu 13.04
Release: 13.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:4.0.2-0ubuntu1
  Candidate: 1:4.0.2-0ubuntu1
  Version table:
 *** 1:4.0.2-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ raring/main i386 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen via a terminal:
cd ~/Desktop && wget -c https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1181738/+attachment/3680887/+files/Chart2%20for%20Realized%20Collaboration%20across%20borders.odg -O example.odg && lodraw --nologo example.odg && libreoffice --nologo --writer

In Draw select all -> Copy -> in Writer Insert -> Frame -> tab Type -> Width 7.52" -> Height 6.13" -> button OK -> click in the newly created frame -> Paste -> Save -> Close and reopen and the picture in Writer looks as it did when copied.

4) What happens instead is the picture has been modified.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: libreoffice-core 1:4.0.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-22.33-generic 3.8.11
Uname: Linux 3.8.0-22-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.9.2-0ubuntu8
Architecture: amd64
Date: Sun May 19 14:30:15 2013
ExecutablePath: /usr/lib/libreoffice/program/soffice.bin
InstallationDate: Installed on 2013-01-13 (125 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MarkForUpload: True
SourcePackage: libreoffice
UpgradeStatus: Upgraded to raring on 2013-04-18 (30 days ago)
Comment 4 QA Administrators 2015-04-01 14:40:08 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-01
Comment 5 Buovjaga 2015-04-19 15:43:42 UTC
The problem in comment 3 is supposed to look like this: https://launchpadlibrarian.net/140233369/missed%20draw%20in%20writer%20document.png

The problem doesn't appear to me. In Writer after save & reload, it looks exactly like in Draw. WFM.

Win 7 Pro 64-bit Version: 5.0.0.0.alpha0+ (x64)
Build ID: 211c12b9c64facd1c12f637a5229bd6a6feb032a
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-18_01:51:17
Locale: fi_FI