Bug Hunting Session
Bug 61316 - VIEWING: Values not shown in cells, only formulae.
Summary: VIEWING: Values not shown in cells, only formulae.
Status: RESOLVED DUPLICATE of bug 60755
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-02-22 23:25 UTC by Larry Johnson
Modified: 2013-02-23 03:17 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
2nd sheet (basic Track data) shows error at F2; spreadsheet contains other errors. (38.27 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-02-22 23:25 UTC, Larry Johnson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Larry Johnson 2013-02-22 23:25:43 UTC
Created attachment 75381 [details]
2nd sheet (basic Track data) shows error at F2; spreadsheet contains other errors.

Problem description: After editing a formula in a spreadsheet created in 3.4, the values is no longer seen but the formula is displayed.

Steps to reproduce:
1. Open spreadsheet created in 3.4
2. Edit a formula (any change)
3. Cell will no longer show value but now shows formula.
4. Go to menu:tools/options, Window:Options/LibreOffice Calc/View...
5. Verify Display/Check-box:Formulas is not checked.
6. Toggle Check-box:Formulas to see if aberrant behavoir change.
7. Observe behavior 3. unchaged. 

Current behavior:
1. Open spreadsheet created in 3.4
2. Edit a formula (any change)
3. Cell will no longer show value but now shows formula.

Expected behavior:
1. Open spreadsheet created in 3.4
2. Edit a formula (any change)
3. Cell show value not formula.

Same behavior in 3.5, bug filed/

              
Operating System: Linux (Other)
Version: 4.0.0.3 release
Last worked in: 3.4.6 release
Comment 1 Larry Johnson 2013-02-22 23:32:18 UTC
Same bug in 3.6.5.2 https://www.libreoffice.org/bugzilla/show_bug.cgi?id=60755
Comment 2 Markus Mohrhard 2013-02-23 03:17:39 UTC
Please report errors only once.

*** This bug has been marked as a duplicate of bug 60755 ***