Download it now!
Bug 61356 - Don't disable editing when the source file is write-protected
Summary: Don't disable editing when the source file is write-protected
Status: RESOLVED DUPLICATE of bug 80538
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: high enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-23 16:32 UTC by Steve Graham
Modified: 2017-01-20 08:48 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Graham 2013-02-23 16:32:08 UTC
If a read-only file is opened (e.g. in Writer), editing functionality is disabled, and a non-modified copy of the file must be saved before any changes can be made.

There is no use case where this makes sense.

A user may or may not wish to save a copy AFTER making changes, but the Save dialog takes care of the issue if the proposed destination is not writeable.

If the user does wish to save the document after editing, having to save it first, before editing, offers no benefit. If the user does not wish to save the changes (say, fixing something before printing), having to save it first, before editing, offers no benefit.

If, for some reason, a copy can't be saved before editing (maybe lack of space), and the document is fundamentally not writeable (say, on a CD), then the user's task is made much more complicated for no reason.
Comment 1 Joel Madero 2013-02-23 20:55:54 UTC
Thank you for writing a bug about this one! I've always thought this as well but never took the time to report (go figure QA not reporting bugs...) ;) 


Marking as NEW (confirmed) and making it "Highest" as I think this slows down work for a ton of people and isn't expected at all.
Comment 2 Björn Michaelsen 2014-01-17 00:43:28 UTC Comment hidden (obsolete)
Comment 3 Justin L 2017-01-20 08:29:05 UTC
fixed during LibreOffice 5.0 development cycle and backported to 4.4 - bug 80538.
    commit c6270de939d5ee51b61dc4ac02c52f1d9b5b1e47
    Author:     Samuel Mehrbrodt <s.mehrbrodtgmail.com>
    CommitDate: Fri Aug 29 03:42:38 2014 -0500
        fdo#80538 Show an infobar when document is in read-only mode
        and remove the Edit icon from the toolbar

*** This bug has been marked as a duplicate of bug 80538 ***