Bug 61357 - DOC import: Equation numbering missing. DATA LOSS when saving.
Summary: DOC import: Equation numbering missing. DATA LOSS when saving.
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DOC-Limitations DOC-Formula
  Show dependency treegraph
 
Reported: 2013-02-23 16:52 UTC by A.S.
Modified: 2020-04-24 12:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Forget this attachment. This is not the file I wanted to upload. (702.53 KB, application/x-zip)
2013-02-23 16:52 UTC, A.S.
Details
Zip file with original document, PDF exports of it on LO and Word. Save as another "doc" from LO and numbers lost. (309.52 KB, application/zip)
2013-02-23 16:56 UTC, A.S.
Details
tdf61357_reduced.doc: used MSO2013 to create a minimal example (31.50 KB, application/msword)
2016-12-03 19:02 UTC, Justin L
Details

Note You need to log in before you can comment on or make changes to this bug.
Description A.S. 2013-02-23 16:52:46 UTC
Created attachment 75412 [details]
Forget this attachment. This is not the file I wanted to upload.

I opened the "orig" doc in the attached test case.
No equation numbering appeared (it did so in MSWord).
After editing a sentence and saving as "*modified.doc", equation numbers disappeared (data loss) and MSWord opened the modified file without equation numbers.
PDFs attached on how LO and Word rendered the "orig" unmodified document.

May be related to bug 57369.
Comment 1 A.S. 2013-02-23 16:56:58 UTC
Created attachment 75413 [details]
Zip file with original document, PDF exports of it on LO and Word. Save as another "doc" from LO and numbers lost.
Comment 2 Jorendc 2013-02-24 14:26:37 UTC
I can confirm this behavior using Mac OSX 10.8.2 with LibreOffice 4.0.0.3 release and compared with Word for Mac 2011.

Kind regards,
Joren
Comment 3 A.S. 2013-11-11 09:57:04 UTC
Just tested, this bug still is "alive" in Version: 4.1.3.2
Id. de compilación: 410m0(Build:2)
Comment 4 A (Andy) 2015-04-04 08:39:55 UTC
Reproducible with LO 4.4.1.2, Win 8.1

Open the attached "Orig" file in MSO and WRITER
Result: 
- MSO shows the equation numbering
- WRITER shows no equation numbering

Save the file in WRITER as a doc file and close and reopen it in MSO and WRITER
Result:
- MSO shows no longer the equation numbering
- WRITER shows instead of the equation numbering "MERGEFORMAT" and at a mouseover the hint "StarOffice.Standard.Modul1.MTPlaceRef"
Comment 5 tommy27 2016-04-16 07:26:12 UTC Comment hidden (obsolete)
Comment 6 A.S. 2016-04-17 18:51:14 UTC
Tested on 5.1.2 (actually 1:5.1.2~rc2-0ubuntu1~wily0) and it is still there: behaviour is the same as in earlier versions.
Comment 7 Justin L 2016-12-03 19:02:29 UTC
Created attachment 129287 [details]
tdf61357_reduced.doc: used MSO2013 to create a minimal example

confirmed still not seeing (1.1) in LO 5.4dev.
Used bibisect43all oldest to confirm that LO has never been able to display the { MACROBUTTON MTPlaceRef \* MERGEFORMAT (1.1)}
Comment 8 QA Administrators 2017-12-22 03:35:35 UTC Comment hidden (obsolete)
Comment 9 A.S. 2017-12-22 08:27:44 UTC
The bug is still present in Libreoffice 5.4.3.2 (the compilation version 5.4.3~rc2-0ubuntu0.17.04.1~lo1 ). Same behaviour: Word 2016 shows the equation numbers, but LO does not, and deletes them on save. [used the doc on the zip file to test].
Comment 10 QA Administrators 2018-12-23 03:49:14 UTC Comment hidden (obsolete)
Comment 11 A.S. 2019-02-07 14:28:45 UTC
Six  years later, still same behaviour as initially reported, now in LibreOffice 6.1.4.2.
Comment 12 Justin L 2020-04-24 12:39:28 UTC
(In reply to A.S. from comment #11)
> Six  years later, still same behaviour as initially reported, now in
> LibreOffice 6.1.4.2.

Of course. What volunteer is ever going to use a macrobutton mergeformat? This kind of bug is only seen by businesses, and they purchase their bug fixes.

repro 7.0+